Tier-2 Mac 10.7 Build fails on Beta

RESOLVED DUPLICATE of bug 1297716

Status

RESOLVED DUPLICATE of bug 1297716
2 years ago
2 years ago

People

(Reporter: cbook, Assigned: wcosta)

Tracking

Details

(URL)

(Reporter)

Description

2 years ago
https://treeherder.mozilla.org/logviewer.html#?job_id=1923053&repo=mozilla-beta 

seems the problem is a configuration problem: 

03:23:05 INFO - checking for target system type... Invalid configuration `x86_64-apple-darwin3.13.0-100-generic': machine `x86_64-apple-darwin3.13.0-100' not recognized
(Reporter)

Comment 1

2 years ago
Greg, Pete: no idea who manages Mac configuration but this seems to be a kind of error. Its tier-2 so no tree closing etc but i guess we should fix this.

Seems this somehow started after the merge from aurora to beta
Flags: needinfo?(pmoore)
Flags: needinfo?(garndt)
(Reporter)

Comment 2

2 years ago
wander, i was told you might know something about the configuration here :)
Flags: needinfo?(wcosta)
Flags: needinfo?(pmoore)
Flags: needinfo?(garndt)
(Assignee)

Comment 3

2 years ago
beta is using universal builds, which is WIP in bug 1183613. The issue is that it is composing the target name with `uname` [1], which returns the Linux kernel version.

[1] http://hg.mozilla.org/releases/mozilla-beta/file/tip/build/macosx/universal/mozconfig.common#l7
Depends on: 1183613
Flags: needinfo?(wcosta)
Even with bug 1183613 we might want to tweak the build config here--IIRC (I tracked this down in another bug) mozharness overrides the osx opt build mozconfig on beta to force a universal build. mshal is going to add a separate cross-universal build in that bug, maybe we should also change the mozharness stuff to not force a universal build, so that we're not doing two separate universal builds?
Hidden, since I'm tired of looking at permared. If, as I suspect, fixing it is P∞, it would be better to stop running it in-tree so I can remove that treeherder exclusion rule now, since there's no more than a 5% chance I'll remember to remove it after the next merge to beta.
Hopefully wander can fix this up?
Assignee: nobody → wcosta
Oh! bug 1297716 was the bug already on file for this.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1297716
You need to log in before you can comment on or make changes to this bug.