BUILDSTATUS messages printed when building with clang + color

RESOLVED FIXED in Firefox 53

Status

RESOLVED FIXED
2 years ago
11 months ago

People

(Reporter: gps, Assigned: gps)

Tracking

(Blocks: 1 bug, {regression})

Trunk
mozilla53
regression
Dependency tree / graph

Firefox Tracking Flags

(firefox50 unaffected, firefox51 unaffected, firefox52 unaffected, firefox53 fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

2 years ago
This is a regression from bug 1171610.

When building with Clang with color enabled, sometimes the output contains "BUILDSTATUS *" messages. These messages are supposed to be slurped away by the build output monitor running in the mach process. However, that isn't working. The likely culprit is terminal control bytes related to coloring.

As was observed in the development of bug 1171610, Clang doesn't "unset" its control codes at the end of every line (GCC does). I thought this was limited to the mach time prefixes being colored incorrectly. I guess it is interfering with BUILDSTATUS output parsing as well :/
Created attachment 8811432 [details]
Screenshot

(In reply to Gregory Szorc [:gps] from comment #0)
> Clang doesn't "unset" its
> control codes at the end of every line (GCC does).

This is likely also why I see timestamps showing up "brighter" occasionally (see attached screenshot).
status-firefox50: --- → unaffected
status-firefox51: --- → unaffected
status-firefox52: --- → unaffected
status-firefox53: --- → affected
(Assignee)

Updated

2 years ago
Assignee: nobody → gps
Status: NEW → ASSIGNED
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 4

2 years ago
mozreview-review
Comment on attachment 8818050 [details]
Bug 1318044 - Issue sgr0 after printing every line;

https://reviewboard.mozilla.org/r/98170/#review99962

WFM!
Attachment #8818050 - Flags: review+
Comment on attachment 8818050 [details]
Bug 1318044 - Issue sgr0 after printing every line;

Flip glandium's r+ flag, since mozreview didn't notice my r+.
Attachment #8818050 - Flags: review?(mh+mozilla) → review+

Comment 6

2 years ago
Pushed by gszorc@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3b0dd252edd7
Issue sgr0 after printing every line; r=froydnj

Comment 7

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/3b0dd252edd7
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox53: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
(Assignee)

Updated

2 years ago
Blocks: 1325181
Version: unspecified → Trunk

Updated

11 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.