Closed Bug 1318136 Opened 5 years ago Closed 5 years ago

Crash reports submitted by the infobar don't get the right process_type assigned

Categories

(Firefox :: General, defect)

51 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1282776
Tracking Status
firefox51 --- affected
firefox52 --- affected
firefox53 --- affected

People

(Reporter: philipp, Unassigned)

References

Details

many of the crash reports that get submitted through the mechanism prompting users to send unsubmitted reports seem to not get the right "process type" field assigned.

for an example see this search query which should only include crashes in the browser process but clearly contains many plugin crashes or crashes in the content process: https://crash-stats.mozilla.com/search/?submitted_from_infobar=__true__&product=Firefox&process_type=browser&_facets=signature&_facets=user_comments&_facets=version#facet-signature

this is skewing crash stats and makes it more difficult to search/filter for the right crashes.
Duping to bug with cause identified.
Also bug 1299964 but it was closed when associated bug was fixed. Didn't deal with general case.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1282776
You need to log in before you can comment on or make changes to this bug.