Closed Bug 1318245 Opened 3 years ago Closed 3 years ago

Intermittent dom/ipc/tests/test_child_docshell.html | application crashed [@ libdvm.so + 0x459f8]

Categories

(Firefox for Android :: Testing, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Firefox 53
Tracking Status
firefox51 --- unaffected
firefox52 --- unaffected
firefox53 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: rbarker)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file, 1 obsolete file)

There have been a couple of other Android dom/ipc test crashes reported recently. Regressed by bug 1312960 perhaps?

:snorp -- Are these tests relevant on Android / should we be running dom/ipc/tests mochitests?
Flags: needinfo?(snorp)
Priority: -- → P3
See Also: → 1318169, 1317887
Crash at 0xdeadd00d, which means Dalvik is aborting. Also I see binder in the stack, so I think this is actually fallout from bug 1314466.
Flags: needinfo?(snorp)
See Also: → 1314466
See comment #2
Assignee: nobody → rbarker
Flags: needinfo?(rbarker)
See Also: → 1318687
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #3)
> See comment #2

Definitely a result of bug 1314466. Testing a patch now. bug 1318687 and this bug are a dup. Any way to know the rate of failure? I'm just wondering how many times I need to run the test to have any level of confidence that the issue may have been addressed.
Flags: needinfo?(rbarker)
See Also: → 1318423
bug 1318423 is also a dup of this issue.
I imagine there may be a few more dups, but they all seem to be one-offs -- not very frequent at all.
Attachment #8812311 - Flags: review?(snorp)
(In reply to Geoff Brown [:gbrown] from comment #7)
> I imagine there may be a few more dups, but they all seem to be one-offs --
> not very frequent at all.

Okay, I'll get my patch reviewed and landed and see if that prevents this particular crash.
Attachment #8812336 - Flags: review?(snorp) → review+
Pushed by rbarker@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0273c38ee88e
Prevent intermittent crash in Fennec by removing unneeded call to IBinder.unlinkToDeath during child service process shutdown r=snorp
See Also: → 1319196
Duplicate of this bug: 1317621
https://hg.mozilla.org/mozilla-central/rev/0273c38ee88e
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
You need to log in before you can comment on or make changes to this bug.