Make it possible to switch on rust-url at runtime

RESOLVED FIXED in Firefox 53

Status

()

Core
Networking
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: manishearth, Assigned: valentin)

Tracking

unspecified
mozilla53
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53 fixed)

Details

(Whiteboard: [necko-active])

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Currently, if MOZ_RUST_URLPARSE is set, each nsStandardURL will contain a mirror RustURL. When parsing/setting, the method is run on both. If there are mismatches when getting, the mismatch is reported via MOZ_LOG.

The inline MOZ_RUST_URLPARSE_FALLBACK define controls whether or not to fall back to the nsStandardURL value when there is a mismatch. It is enabled by default, but can be disabled to get an idea of what tests will fail with RustURL.

We should have a runtime pref that controls the fallback.
(Assignee)

Comment 1

a year ago
Created attachment 8812762 [details] [diff] [review]
Make it possible to switch on rust-url at runtime

MozReview-Commit-ID: 3BfqFWIpS7F
(Assignee)

Updated

a year ago
Assignee: nobody → valentin.gosu
Status: NEW → ASSIGNED
(Assignee)

Comment 2

a year ago
Comment on attachment 8812762 [details] [diff] [review]
Make it possible to switch on rust-url at runtime

Review of attachment 8812762 [details] [diff] [review]:
-----------------------------------------------------------------

This patch adds a runtime pref to enable the rust parser. It defaults to false as we have discovered several regressions (both crashes and performance) caused by bug 1151899.
Attachment #8812762 - Flags: review?(daniel)
(Assignee)

Updated

a year ago
Whiteboard: [necko-active]
Attachment #8812762 - Flags: review?(daniel) → review+

Comment 5

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/688a4bbf8018
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox53: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
it appears that this change caused many performance improvements:
https://treeherder.mozilla.org/perf.html#/alerts?id=4261
(Reporter)

Comment 7

a year ago
More accurately, it fixed a perf regression caused by https://bugzilla.mozilla.org/show_bug.cgi?id=1151899 :)
You need to log in before you can comment on or make changes to this bug.