Closed Bug 1318663 Opened 3 years ago Closed 3 years ago

Tapping on 'New Tab' from Search Activity widget doesn't open a new one if the Restore tab is set to always restore

Categories

(Firefox for Android Graveyard :: Search Activity, defect)

53 Branch
ARM
Android
defect
Not set

Tracking

(fennec+, firefox51 affected, firefox52 affected, firefox53 verified)

RESOLVED FIXED
Firefox 53
Tracking Status
fennec + ---
firefox51 --- affected
firefox52 --- affected
firefox53 --- verified

People

(Reporter: sflorean, Assigned: maliu)

References

Details

Attachments

(1 file)

Environment: 
Device: LG G4 (Android 6.0.1);
Build: Nightly 53.0a1 (2016-11-17);

Prerequisite:
Menu-> Settings-> Advanced-> Restore tabs-> Always restore enabled.

Steps to reproduce:
1. Go to Fennec and open 4-5 pages in different tabs;
2. Close Fennec from Task Manager;
3. Tap on 'New Tab' button from the Search Activity widget.

Expected result:
- Fennec is launched and a new tab is opened.
- The number of tabs is increased.

Actual results:
Fennec is launched but there is no new tab opened. Only the tabs from step 1.
tracking-fennec: --- → ?
Assignee: nobody → max
tracking-fennec: ? → +
Comment on attachment 8814046 [details]
Bug 1318663 - Don't skip load start tab during tab restore if incoming action of intent is VIEW with non-external URL.

https://reviewboard.mozilla.org/r/95368/#review95704

This fixes the widget but also changes the behavior of the app:

Whenever the app/activity is resumed from a destroyed state we will open a new tab with that patch.
Attachment #8814046 - Flags: review?(s.kaspari) → review-
Attachment #8814046 - Flags: review?(jh+bugzilla)
Comment on attachment 8814046 [details]
Bug 1318663 - Don't skip load start tab during tab restore if incoming action of intent is VIEW with non-external URL.

https://reviewboard.mozilla.org/r/95368/#review96064

LGTM with the unrelated changes removed. JanH: Do you see any issues from the session/restore point of view?

::: mobile/android/base/java/org/mozilla/gecko/GeckoApp.java
(Diff revision 3)
> -import org.mozilla.gecko.AppConstants.Versions;
> -import org.mozilla.gecko.GeckoProfileDirectories.NoMozillaDirectoryException;
> -import org.mozilla.gecko.annotation.RobocopTarget;
> -import org.mozilla.gecko.db.BrowserDB;
> -import org.mozilla.gecko.db.UrlAnnotations;
> -import org.mozilla.gecko.gfx.BitmapUtils;
> -import org.mozilla.gecko.gfx.FullScreenState;
> -import org.mozilla.gecko.gfx.LayerView;
> -import org.mozilla.gecko.health.HealthRecorder;

Lots of unrelated imports movement here.

::: mobile/android/base/java/org/mozilla/gecko/GeckoApp.java:2293
(Diff revision 3)
> +    public void showSDKVersionError() {
> +        final String message = getString(R.string.unsupported_sdk_version, Build.CPU_ABI, Build.VERSION.SDK_INT);
> +        Toast.makeText(this, message, Toast.LENGTH_LONG).show();
> +    }
> +

The move of this method seems to be unrelated too.
Attachment #8814046 - Flags: review?(s.kaspari)
Attachment #8814046 - Flags: review?(jh+bugzilla)
Comment on attachment 8814046 [details]
Bug 1318663 - Don't skip load start tab during tab restore if incoming action of intent is VIEW with non-external URL.

https://reviewboard.mozilla.org/r/95368/#review96132
Attachment #8814046 - Flags: review?(s.kaspari) → review+
Comment on attachment 8814046 [details]
Bug 1318663 - Don't skip load start tab during tab restore if incoming action of intent is VIEW with non-external URL.

https://reviewboard.mozilla.org/r/95368/#review96134

No objections - tab restoring has already happened at that point and this doesn't seem fundamentally different from just opening an URL from an external app.
Attachment #8814046 - Flags: review?(jh+bugzilla) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/be6f5b8a484e
Don't skip load start tab during tab restore if incoming action of intent is VIEW with non-external URL. r=JanH,sebastian
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/be6f5b8a484e
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Verified as fixed in build 53.0a1 (2016-12-05);
Device: AsusZen Pad 8 (Android 6.0.1).
See Also: → 1323437
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.