Closed Bug 1318822 Opened 3 years ago Closed 2 years ago

Search suggestions do not show with respect to the language settings

Categories

(Firefox for Android :: Awesomescreen, defect, P3)

49 Branch
All
Android
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
fennec + ---

People

(Reporter: johnlinp, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160920074044

Steps to reproduce:

I set my language preference to zh-TW, and enabled search suggestion. Then go type something like "台" in the search box.


Actual results:

The search suggestions shows "台湾" and "台湾新闻", which are in zh-CN.


Expected results:

In my desktop version of Firefox, it shows "台鐵", "台灣銀行", which are actually in zh-TW.
OS: Unspecified → Android
Hardware: Unspecified → All
Summary: Search suggestions are not limited to the language settings → Search suggestions do not show with respect to the language settings
tracking-fennec: --- → ?
Status: UNCONFIRMED → NEW
tracking-fennec: ? → +
Ever confirmed: true
Assignee: nobody → walkingice0204
It only effects Google search suggestion. In here[1] we provide search template without specifying language, then Google fallback to Simplified-Chinese results.

But I have no idea why Desktop version wont be effect.

[1] https://dxr.mozilla.org/mozilla-central/rev/bad312aefb42982f492ad2cf36f4c6c3d698f4f7/browser/locales/searchplugins/google-nocodes.xml#10
Setting priority to P1 for TW users.
Priority: -- → P1
This is an assigned P1 bug without activity in two weeks. 

If you intend to continue working on this bug for the current release/iteration/sprint, remove the 'stale-bug' keyword.

Otherwise we'll reset the priority of the bug back to '--' on Monday, August 28th.
Keywords: stale-bug
Component: Search Activity → Awesomescreen
[triage] If this affects one locale, seems non-critical but if it affects more, it could be important: leaving P1.
Assignee: walkingice0204 → nobody
Keywords: stale-bug
Action item: determine if this affects more than TW and consult upper triage.
Flags: needinfo?(michael.l.comella)
Mike, I think without further reports from the field, we can assume this only affects one locale, and keep it a P3 until we have more eng resources. Let me know if you disagree.
Priority: P1 → P3
I am the original reporter. I am using version 57.0.4 and I can't reproduce this problem. Thos ticket may be closed. Thabks.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
Thanks for following up! :)
Flags: needinfo?(michael.l.comella)
You need to log in before you can comment on or make changes to this bug.