All users were logged out of Bugzilla on October 13th, 2018

Electrolysis crashes tab when user quickly opens multiple

RESOLVED DUPLICATE of bug 1294719

Status

()

--
critical
RESOLVED DUPLICATE of bug 1294719
2 years ago
2 years ago

People

(Reporter: jrg488, Unassigned)

Tracking

({crash})

50 Branch
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161104212021

Steps to reproduce:

Opened multiple tabs rapidly from one page


Actual results:

Apparently this has to do with Electrolysis - it seems to be unable to distinguish malicious activity from a user simply quickly opening multiple links. This causes the tab from which tabs are being opened to crash, and all the others to do so as well.


Expected results:

The tabs should have opened as normal, as they have in every previous Firefox release.

Comment 1

2 years ago
Do you have link of crash reports from the page about:crashes to copy?
Severity: normal → critical
Flags: needinfo?(jrg488)
Keywords: crash

Comment 3

2 years ago
It's fixed in FF51+ and a request to backport the fix into FF50 has been requested.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(jrg488)
Resolution: --- → DUPLICATE
Duplicate of bug: 1294719
You need to log in before you can comment on or make changes to this bug.