Intermittent Talos NoSuchProcess: psutil.NoSuchProcess process no longer exists (pid=3056, name=u'firefox.exe') (timeout)

RESOLVED DUPLICATE of bug 1236770

Status

Testing
Talos
RESOLVED DUPLICATE of bug 1236770
a year ago
a year ago

People

(Reporter: aryx, Unassigned)

Tracking

({intermittent-failure})

Version 3
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

https://treeherder.mozilla.org/logviewer.html#?job_id=6901102&repo=autoland

01:21:09     INFO -  PROCESS | 3056 | Loaded: http://localhost:50003/tests/tp5n/amazon.com/www.amazon.com/Kindle-Wireless-Reader-Wifi-Graphite/dp/B002Y27P3M/507846.html
01:21:09     INFO -  PROCESS | 3056 | Loads complete - starting tab switches
01:21:10     INFO -  PROCESS | 3056 | http://localhost:50003/tests/tp5n/cgi.ebay.com/cgi.ebay.com/ALL-NEW-KINDLE-3-eBOOK-WIRELESS-READING-DEVICE-W-WIFI-/130496077314@pt=LH_DefaultDomain_0&hash=item1e622c1e02.html: 43ms
01:21:11     INFO -  PROCESS | 3056 | http://localhost:50003/tests/tp5n/163.com/www.163.com/index.html: 29ms
01:21:12     INFO -  PROCESS | 3056 | http://localhost:50003/tests/tp5n/mail.ru/mail.ru/index.html: 62ms
02:15:33     INFO -  Terminating psutil.Process(pid=3056, name=u'firefox.exe')
02:15:36     INFO -  TEST-UNEXPECTED-ERROR | tps | psutil.NoSuchProcess process no longer exists (pid=3056, name=u'firefox.exe')
02:15:36    ERROR -  Traceback (most recent call last):
02:15:36     INFO -    File "C:\slave\test\build\tests\talos\talos\run_tests.py", line 202, in run_tests
02:15:36     INFO -      talos_results.add(mytest.runTest(browser_config, test))
02:15:36     INFO -    File "C:\slave\test\build\tests\talos\talos\ttest.py", line 70, in runTest
02:15:36     INFO -      return self._runTest(browser_config, test_config, setup)
02:15:36     INFO -    File "C:\slave\test\build\tests\talos\talos\ttest.py", line 174, in _runTest
02:15:36     INFO -      if counter_management else None),
02:15:36     INFO -    File "C:\slave\test\build\tests\talos\talos\talos_process.py", line 132, in run_browser
02:15:36     INFO -      return_code = context.kill_process()
02:15:36     INFO -    File "C:\slave\test\build\tests\talos\talos\talos_process.py", line 37, in kill_process
02:15:36     INFO -      self.process.terminate()
02:15:36     INFO -    File "C:\slave\test\build\venv\lib\site-packages\psutil\__init__.py", line 299, in wrapper
02:15:36     INFO -      raise NoSuchProcess(self.pid, self._name)
02:15:36     INFO -  NoSuchProcess: psutil.NoSuchProcess process no longer exists (pid=3056, name=u'firefox.exe')
02:15:36     INFO -  TEST-INFO took 3610692ms
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1236770
You need to log in before you can comment on or make changes to this bug.