Intermittent drawFocusIfNeeded.html == drawFocusIfNeeded-ref.html | image comparison, max difference: 128, number of differing pixels: 816

RESOLVED DUPLICATE of bug 1316549

Status

Testing
Reftest
RESOLVED DUPLICATE of bug 1316549
11 months ago
11 months ago

People

(Reporter: Treeherder Bug Filer, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 months ago
treeherder
Filed by: archaeopteryx [at] coole-files.de

https://treeherder.mozilla.org/logviewer.html#?job_id=39516729&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/Uj6gCYywT5m2yvXnWZ5okQ/runs/0/artifacts/public/logs/live_backing.log

https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/Uj6gCYywT5m2yvXnWZ5okQ/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1
I see this when I run reftests on linux32 via taskcluster:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=e3102a63b0db9fafef52ab6cf34d2ce82ab89bb4&selectedJob=31587952&filter-searchStr=r4

same reftest analyzer display.
Blocks: 1287099

Comment 2

11 months ago
25 failures in 113 pushes (0.221 failures/push) were associated with this bug yesterday.  

Repository breakdown:
* autoland: 12
* mozilla-inbound: 8
* graphics: 3
* mozilla-central: 2

Platform breakdown:
* linux64: 25

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1318953&startday=2016-11-21&endday=2016-11-21&tree=all

Comment 3

11 months ago
Here's an early regression range: https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&fromchange=f09e137ead39230eaa94f47988ccce2cfcda4195&noautoclassify&bugfiler&group_state=expanded&filter-searchStr=5593e5242f05455f2787a2e4bad76ad9eded4fcf&tochange=d5d357b7ca3095e311add0e06bf9027cb9c5dce7

Comment 4

11 months ago
212 failures in 141 pushes (1.504 failures/push) were associated with this bug yesterday.  

Repository breakdown:
* autoland: 104
* mozilla-inbound: 98
* mozilla-central: 7
* try: 3

Platform breakdown:
* linux64: 212

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1318953&startday=2016-11-22&endday=2016-11-22&tree=all
and a range on m-i:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&filter-searchStr=Linux%20x64%20opt%20Reftests%20executed%20by%20TaskCluster%20desktop-test-linux64%2Fopt-reftest-no-accel-4%20tc-R(Ru4)&tochange=de975fd9cbf654f2b1c17db01a7544995da65611&fromchange=957dff87958ea8bda3d0e772fb15db03899a9d83

unfortunately we cannot backfill, or even add new jobs manually- so I cannot narrow it down

Comment 6

11 months ago
this pretty frequent failing now

Comment 7

11 months ago
Yeah, this has spiked to #2 on orangefactor for the week in just three days, so this will probably get skipped pretty quickly.

Updated

11 months ago
OS: Unspecified → Linux
Hardware: Unspecified → All

Comment 8

11 months ago
(In reply to Joel Maher ( :jmaher) from comment #5)
> and a range on m-i:
> https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&filter-
> searchStr=Linux%20x64%20opt%20Reftests%20executed%20by%20TaskCluster%20deskto
> p-test-linux64%2Fopt-reftest-no-accel-4%20tc-
> R(Ru4)&tochange=de975fd9cbf654f2b1c17db01a7544995da65611&fromchange=957dff879
> 58ea8bda3d0e772fb15db03899a9d83
> 
> unfortunately we cannot backfill, or even add new jobs manually- so I cannot
> narrow it down

Excitingly, my try runs[1] make it look like it started on the merge back from m-c to inbound, which is somewhat upsetting.


1. https://treeherder.mozilla.org/#/jobs?repo=try&author=kwierso@gmail.com&fromchange=c87f03130dedc8b467747b360d85f589bed8ecd1&group_state=expanded&filter-searchStr=ru4 (Click the hg revision to go to the commit, then compare the "parent" revs against jmaher's range.

Comment 9

11 months ago
246 failures in 124 pushes (1.984 failures/push) were associated with this bug yesterday.  

Repository breakdown:
* mozilla-inbound: 132
* autoland: 96
* mozilla-central: 8
* graphics: 6
* try: 4

Platform breakdown:
* linux64: 245
* android-4-3-armv7-api15: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1318953&startday=2016-11-23&endday=2016-11-23&tree=all
This is frequent on the merge from m-i to m-c 0534254e9a40, but not on its m-c parent 46e4cd888213

https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&fromchange=46e4cd888213&noautoclassify&bugfiler&group_state=expanded&filter-searchStr=5593e5242f05455f2787a2e4bad76ad9eded4fcf&tochange=0534254e9a40

And it is not frequent on the inbound parent c7be1246b301
https://treeherder.mozilla.org/#/jobs?repo=try&revision=9f7f784a9eb5cf0d158f5ad352b3b5c67a303689

So apparently
https://hg.mozilla.org/mozilla-central/log?rev=ancestors(46e4cd888213)-ancestors(c7be1246b301)&revcount=150
did not merge well with
https://hg.mozilla.org/integration/mozilla-inbound/log?rev=ancestors(c7be1246b301)-ancestors(46e4cd888213)&revcount=200

The earliest failure I've found was e79129082f4a, which was in that inbound
range (before the merge 0534254e9a40), but that failed only once out of 40 runs.

https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&filter-searchStr=linux%20x64%20opt%20reftests%20executed%20by%20taskcluster%20desktop-test-linux64%2Fopt-reftest-no-accel-4%20tc-r(r&tochange=e79129082f4a&fromchange=4fefdb64d28f
The test specifies needs-focus, but the harness does not wait for focus before running the tests, or even warn when it has not received focus.
Component: Canvas: 2D → Reftest
Product: Core → Testing
The logging added in https://treeherder.mozilla.org/#/jobs?repo=try&revision=685ea7623bb5c25fe68ece2b3520d281dfc6f4e5&selectedJob=31793140
confirms that onfocus is not called.

I've also run the test locally and the harness proceeded without waiting for focus.

Comment 13

11 months ago
65 failures in 114 pushes (0.57 failures/push) were associated with this bug yesterday.  

Repository breakdown:
* mozilla-inbound: 48
* autoland: 15
* mozilla-central: 2

Platform breakdown:
* linux64: 64
* android-4-3-armv7-api15: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1318953&startday=2016-11-24&endday=2016-11-24&tree=all
And then it quite clearly stopped on autoland Wednesday night, then on central and inbound Thursday morning when autoland was merged to them. Inconveniently, where it stopped was with https://hg.mozilla.org/integration/autoland/rev/5ac0fb38b65024441bcc38bf899ea686c283e798, a gtest-only patch that certainly couldn't possibly have affected it.

Comment 15

11 months ago
592 failures in 623 pushes (0.95 failures/push) were associated with this bug in the last 7 days. 

This is the #1 most frequent failure this week. 

** This failure happened more than 50 times this week! Resolving this bug is a high priority. **

Repository breakdown:
* mozilla-inbound: 315
* autoland: 232
* mozilla-central: 22
* graphics: 15
* try: 8

Platform breakdown:
* linux64: 590
* android-4-3-armv7-api15: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1318953&startday=2016-11-21&endday=2016-11-27&tree=all

Comment 16

11 months ago
With retries, looks very much like bug 1316549 fixed this - yahoo!
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1316549
You need to log in before you can comment on or make changes to this bug.