WebVR 1 and Cardboard display

RESOLVED WONTFIX

Status

()

Firefox for Android
General
RESOLVED WONTFIX
a year ago
a year ago

People

(Reporter: Daniel, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.116 Safari/537.36

Steps to reproduce:

Hi there , there seems to be an issue getting a display in Cardboard mode in WebVR 1 in Firefox Nightly. No display is returned. In Chrome a display is returned but it's not presentable. 

In Firefox stable 49 the deprecated WebVR works however the position controls is broken because the orientation api events are also broken on my device which another ticket is for. 

I see some previous tickets in regards to WebVR for cardboard but it's possible not for WebVR 1. 

Let me know what is possible thanks. 

function gotVRDisplays( displays ) {

		vrDisplays = displays;

		if ( displays.length > 0 ) {

			vrDisplay = displays[ 0 ];

		} else {

			if ( onError ) onError( 'HMD not available' );

		}

	}

navigator.getVRDisplays().then( gotVRDisplays ).catch( function() {

			

		} );


Actual results:

vrDisplay is an empty array


Expected results:

A WebVR display device for cardboard mode.
Flags: needinfo?(s.kaspari)
tracking-fennec: --- → ?
Flags: needinfo?(s.kaspari)
(Reporter)

Comment 1

a year ago
According to this it was removed intentionally 

https://bugzilla.mozilla.org/show_bug.cgi?id=1318293#c8

See actual removal comment and ticket

https://bugzilla.mozilla.org/show_bug.cgi?id=1250244#c40

I had to make comments on another ticket because removal relies back on the orientation events which now have a regression with certain Android devices. 

https://bugzilla.mozilla.org/show_bug.cgi?id=1318293#c9
So I guess this can be closed. @kip: What do you think?
Flags: needinfo?(kgilbert)
(Reporter)

Comment 3

a year ago
Is there a reason for removal  if it was working fine in the previous version of WebVR ?
(In reply to Daniel from comment #3)
> Is there a reason for removal  if it was working fine in the previous
> version of WebVR ?

The prior implementation had hard coded values such as the display resolution and regressions caused it to crash the browser in later releases.  Essentially, it was not of shippable quality and was preventing sites from falling back to the polyfill libraries that worked equally well on Android.

The WebVR 1.1 implementation includes a VR dedicated rendering path for lower latency rendering.  This is being updated to support more platforms (currently Windows only).  At that point, it will be worth re-implementing the Cardboard support for Android to enable these improvements on mobile.

@sebastian: I think we could close this bug, but track the orientation event regression in Bug 1318293.
Flags: needinfo?(kgilbert)
(Reporter)

Comment 5

a year ago
ok sorry about that not a problem.
(Reporter)

Comment 6

a year ago
OK not a problem. So mobile will for now be stuck on stereo webgl rendering and orientation apis if they ever work for now. Even though the WebVR 1 apis are there. 

Maybe the only platform that may support WebVR 1 is gear and google headset with appropriate browsers. For Gear it would be the Gear VR browser with WebVR flags enabled
Thanks! I flagged bug 1318293 for triage later today.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.