Closed Bug 1319085 Opened 5 years ago Closed 5 years ago

Session Restore is broken. Port Bug 944694 part 2 to SeaMonkey

Categories

(SeaMonkey :: Session Restore, defect)

defect
Not set
normal

Tracking

(seamonkey2.49esr unaffected, seamonkey2.50 fixed)

RESOLVED FIXED
seamonkey2.50
Tracking Status
seamonkey2.49esr --- unaffected
seamonkey2.50 --- fixed

People

(Reporter: frg, Assigned: frg)

References

Details

Attachments

(1 file)

Update SessionStore and restore to use the new docshellID format.
What session restore do we talk about?
- after Crash?
- When launch if Preference is "Restore previous session"?
- Both?
- Something else?
NOT reproducible with Server-Installation of  unofficial (by FRG) en-US SeaMonkey 2.49a2  (NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 Build 20161118170316  (Default Classic Theme) on German WIN7 64bit?
I crashed SM due to "Bug 1224326 - CRASH when pause → continue download several times", after relaunch Session became restored without problems.

a) SM 2.50 related?
>> What session restore do we talk about?

Both. This one is 2.50+ specific. I will see that I get it fixed next weekend if no one else chimes in.

There is another bug in _serializeSessionStorage which also affects 2.49. jarprefix is gone. Need to file a bug.

FRG
More or less REPRODUCIBLE with Server-Installation of  unofficial (by FRG) en-US SeaMonkey 2.50a1 (NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0 Build 20161121115504  (Default Classic Theme) on German WIN7 64bit:

1. In Browser open some TABs
2. MenuˋEdit → Preferences → Browser - select "Restore previous session" + "Restore
   all TABs immediatelyˊ
3. Quit and relaunch SeaMonkey (browser)
   Expected: All TABs from last session restored with contents from session before.

I see at least 2 unexpected effects
a) Nonsense TAB(s) appear, mostly for a nonsense internet search. I never 
   saw that before
b) restored TABs are without contents, only grey area shown.
   this is not completely new for me, I already saw this occasionally in 2.49,
   but with 2.50 this problem seems to be 100% reproducible. 

Additional observations
c) Mostly it is impossible to restore contents for URL shown in location bar:
c1) 'Reload' icon click seems not to help
c2) 'Rightclick TAB Header → Reload TAB' sometimes restores TAB contents
c3) 'Clear Cache' might increase chance of success for (c2), but I am not sure
d) The problem seems to be in "save session", not in "restore session":
d1) If I quit SeaMonkey 2.48 and afterwards launch 2.50, all TABs from 
    2.48 session will be restored in a perfect way
d2) When I Quit SM 2.50 and relaunch 2.50 again, restored TABs will be empty
Straight port.

Tested by saving session in 2.49a2 and upgrading to 2.50a1 and also by saving and restoring a session in 2.50a1. 

With the patch the file sessionstore.json will contain UUIDs in the form of "docshellUUID":"{c2db7c98-accb-4e74-88f4-675ed58d8bf0}".
Assignee: nobody → frgrahl
Status: NEW → ASSIGNED
Attachment #8814565 - Flags: review?(philip.chee)
No longer reproducible with Server-Installation of  unofficial (by FRG) en-US SeaMonkey 2.50a1 (NT 6.1; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0 Build 20161126153243  (Default Classic Theme) on German WIN7 64bit.

I do not know whether "1319085-DocShellUUID.patch" is integrated
>> I do not know whether "1319085-DocShellUUID.patch" is integrated

It is. Thanks for the confirmation.
Comment on attachment 8814565 [details] [diff] [review]
1319085-DocShellUUID.patch

r=me
Attachment #8814565 - Flags: review?(philip.chee) → review+
https://hg.mozilla.org/comm-central/rev/694e6d442dc88c7838ed6e466d1ba978bf9f08c4
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.50
You need to log in before you can comment on or make changes to this bug.