Closed Bug 1319201 Opened 3 years ago Closed 3 years ago

background page iframe cross-origin permission

Categories

(WebExtensions :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1214373

People

(Reporter: angelosimonetti1982, Unassigned)

Details

(Whiteboard: triaged)

In add-on sdk there is the page-worker,
in the webextensions guidelines there is wrote:
Use the background page, or load remote iframes into the background page.

In background html page there are 2 frame, in the background script I will assign the src value to www.google.com www.example.com, but when I try to get iframe contents I got permission denied.

It is possibile to do the same thinks of page-worker? how?
(it can be useful to add a sample in the webextensions guide)
Flags: needinfo?(kmaglione+bmo)
Whiteboard: triaged
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(kmaglione+bmo)
Resolution: --- → DUPLICATE
Duplicate of bug: 1214373
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.