Closed Bug 131938 Opened 23 years ago Closed 22 years ago

Subfolders exist but are not shown (IMAP)

Categories

(MailNews Core :: Networking: IMAP, defect)

x86
Windows NT
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 138759

People

(Reporter: lovis28, Assigned: mscott)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

If I create a new subfolder (or subfolder of a subfolder) and set it on
subscribe, I can see that subfolder in this list but not in my regular mail
browser name list. Actually I can see it _sometimes_ but not always. I can also
_sometimes_ move mails in these folders and othertimes I get an error message
(folder does not exist). 

Reproducible: Sometimes
Steps to Reproduce:
1.Create new subfolders
2.Move messages in there
3.Subscribe

Actual Results:  It seemed that it would work but after restart Mozilla these
subfolders were gone.

Expected Results:  Show subfolders always.

I also tried different server settings. (advanced: server supports folders that
contain sub-folders and messages - is on)
This looks like something I am seeing with 0.9.9 that I didn't see as much with
0.9.7. I can't select some of my deeply nested folders anymore. Their parent
folders are greyed out in the folder sidebar as well as under the "File" button.
There may be subfolders, but there is no "+" or "-" sign next to them in the tree
view. Even folding and unfolding the tree one level up doesn't help (that used to
help with older versions when I've seen this before). I'm using "show all
folders", not "show only subscribed folders", but in the subscription dialog all
subfolders are properly shown. I don't have the same folders "unreachable" on
each invocation of mozilla, but it looks like I always have some in this state.

Buildid: 2002031115
Why isn't anybody doing anything about this?
:-(
What kind of the IMAP Server are you using?
Does the IMAP server make a difference here? As said above, the "subscription"
dialog properly shows everything. With 1.1alpha (beta not yet in RPM's) I am
seeing different subsets of folders in the side-bar and in the "File" menu....

Using Washington IMAP here.

HELP!
See also 86968
I'm seeing this exact same bug with Mozilla 1.2b for Linux (downloaded
10/17/02). Subfolders simply aren't displayed -- I tried refreshing my folder
list, quit Mozilla and deleted the server directory (rm -rf
~/.mozilla/<username>/<profile>/ImapMail/*), but it made no difference.

I reverted to Mozilla 1.2a and it works fine; all my subfolders are there.

We're using UW-IMAP if it matters.
I'm having this problem too

using courrier-imap

I haven't had any problem with previous mozilla builds 
now using

Mozilla 1.2b
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016
I'm using mozilla1.2b 
Aditional: When having opened all folders using mozilla1.1 + letting them open
when shutting down mozilla, all subfolders are visible in 1.2.
When closing a  folder there is again no possibility to open it - no triangle icon 
visible.

kind regards
Norbert
I use build 2002111311 for the junk mail feature. I tried a more recent build to
see if "move junk mail" is enabled. After returning to the build I use, the imap
folders dissapeared. I used mozilla 1.0 to subscribe to them again. I have all
my folders and subfolders again but:

subfolders into subfolders don't apper.

I can see "looking for folders" when I click on a folder, but this seems to not
happen when I click on a subfolder. Is this the cause they are not showing? they
don't show in the subscribe window too.

This is folder/subfolder/sub-subfolder, and sub-subfolder does not appear.



The problem is still there with Mozilla 1.2.1 (Windows version, OS is XP prof.).
Is there anyone to fix this?

Roland.
this problem has dissapeared for me in 1.2 and 1.2.1

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130
QA Contact: huang → gchan
We have found that simply closing and opening the treeview for the folder above
the missing folders in the mail account list causes the missing folders to
appear.  (version 1.3a).

*** This bug has been marked as a duplicate of 138759 ***
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
This is a dupe of bug 138759, please update your votes.
bug 138759 says: Deeply nested IMAP folders aren't seen by Mozilla until parent
gets folded and unfolded

This is not the case. This bug is about existing IMAP folders that are not shown
because I can't subscribe to them.

Thanks.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.