the latest version can not find 'add watch' in debugger tool

RESOLVED FIXED

Status

DevTools
Debugger
P2
normal
RESOLVED FIXED
2 years ago
a month ago

People

(Reporter: dyh333, Unassigned)

Tracking

(Blocks: 1 bug)

52 Branch

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

2 years ago
What did you do?
================
the latest version can not find 'add watch' in debugger tool

What happened?
==============
the latest version can not find 'add watch' in debugger tool

What should have happened?
==========================
the latest version can not find 'add watch' in debugger tool

Is there anything else we should know?
======================================
Component: BrowserCompat → Untriaged
Product: Mozilla Developer Network → Firefox

Comment 1

2 years ago
Which version are you using?
Component: Untriaged → Developer Tools
Flags: needinfo?(dyh333)

Updated

2 years ago
Component: Developer Tools → Developer Tools: Debugger
I can reproduce this on recent Dev Edition / Aurora channel builds (e.g. 52.0a2 build id 20161217004004); apparently there is no way to add watches in the new debugger: https://developer.mozilla.org/en-US/docs/Tools/Debugger/How_to/Examine,_modify,_and_watch_variables

It seems from poking around that watches are implemented but are turned off behind a feature flag pending some UI tweaks: https://github.com/devtools-html/debugger.html/issues/916

Clearly this should block removing the old debugger (bug 1314057).

Updated

2 years ago
Blocks: 1314057
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(dyh333)
OS: Other → All
Whiteboard: [specification][type:bug]
Version: unspecified → 52 Branch
It looks like this was already fixed in https://github.com/devtools-html/debugger.html/issues/1596.

James, can you tell when those changes will be merged into mozilla-central?

Sebastian
Flags: needinfo?(jlong)
The next land of the new debugger in Nightly will include Watch Expressions.
Priority: -- → P2
Flags: needinfo?(jlong)
I though so. The question was rather when that land will happen. :-) I assume the last one was several months ago.

Sebastian
(In reply to Sebastian Zartner [:sebo] from comment #5)
> I assume the last one was several months ago.

bug 1331654 just landed 3 days ago but didn't include this fix.  Next land, planned for a week or so from now should include it.
(In reply to Bryan Clark (DevTools PM) [:clarkbw] from comment #6)
> (In reply to Sebastian Zartner [:sebo] from comment #5)
> > I assume the last one was several months ago.
> 
> bug 1331654 just landed 3 days ago but didn't include this fix.  Next land,
> planned for a week or so from now should include it.

I see. Sorry, I totally missed this update! Thank you for the info!

Sebastian
Oh, this has landed for a while now.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.