Inspector sidebar is broken when devtools.layoutview.enabled is set to true

VERIFIED FIXED in Firefox 52

Status

()

Firefox
Developer Tools: Inspector
VERIFIED FIXED
7 months ago
7 months ago

People

(Reporter: sebo, Assigned: gl)

Tracking

({regression})

53 Branch
Firefox 53
regression
Points:
---

Firefox Tracking Flags

(firefox50 unaffected, firefox51 unaffected, firefox52 verified, firefox53 verified)

Details

(Whiteboard: [testday-20161125] )

Attachments

(1 attachment)

(Reporter)

Description

7 months ago
When the preference devtools.layoutview.enabled is set to true the Inspector sidebar can't be opened anymore.

The Browser Console shows the following related errors:

fileName:"resource://devtools/client/shared/browser-loader.js"
lineNumber:125
message:"Module `resource://devtools/client/inspector/layout/components/app.js` is not found at resource://devtools/client/inspector/layout/components/app.js"

TypeError: sidePaneContainer is null[Learn More] inspector.js:1378:11

Sebastian
(Reporter)

Comment 1

7 months ago
mozregression spit out bug 1314931.

Related regression range was:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=95f2069670c668c07e984d225d1829b017212db3&tochange=3d032c10f6cc6d16ee04533ea7a218bf1ec4491d

Sebastian
Blocks: 1314931
Has Regression Range: --- → yes
status-firefox50: --- → unaffected
status-firefox51: --- → unaffected
status-firefox52: --- → affected
Keywords: regression
CC'ing Gabriel as this is something we might want to get to rather quickly.
Thanks Sebastian for filing.
(Assignee)

Comment 3

7 months ago
Created attachment 8813999 [details] [diff] [review]
1320010.patch

Surprised this didn't report an error on MacOSX and continued to work. This should fix it.
Assignee: nobody → gl
Status: NEW → ASSIGNED
Attachment #8813999 - Flags: review?(jdescottes)
Comment on attachment 8813999 [details] [diff] [review]
1320010.patch

Review of attachment 8813999 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the quick fix! Mind logging a follow up to add a test?

> Surprised this didn't report an error on MacOSX and continued to work.

From what I tested, it works on a local build on OSX, but fails on a Nightly build.
This might be coming from the fact that local builds use symlinks for some files instead of really packaging them.
Which means they benefit of the case insensitive file system used on OSX.
Attachment #8813999 - Flags: review?(jdescottes) → review+
(Assignee)

Comment 5

7 months ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/e13ca676d63607f1a19a73c77b7331253d0e2ba8
Bug 1320010 - Fix incorrect file reference to devtools/inspector/client/layout/components/App. r=jdescottes

Comment 6

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e13ca676d636
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
status-firefox53: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
(Reporter)

Comment 7

7 months ago
Thank you for the very fast fix! I think this should be backported to 52.

Sebastian
(Assignee)

Comment 8

7 months ago
Comment on attachment 8813999 [details] [diff] [review]
1320010.patch

Approval Request Comment
[Feature/regressing bug #]:
[User impact if declined]: Inspector won't open.
[Describe test coverage new/current, TreeHerder]: None, because it is a path fix.
[Risks and why]: 
[String/UUID change made/needed]:
Attachment #8813999 - Flags: approval-mozilla-aurora?
It helps people taking the decision to uplift this if they are given a bit more information about the request. So let me add a few more details:
> Approval Request Comment
> [Feature/regressing bug #]: bug 1314931
> [User impact if declined]: If the pref devtools.layoutview.enabled is set to true (it is false by default), then the Inspector panel in DevTools won't open.
> [Describe test coverage new/current, TreeHerder]: None, because it is a path fix.
> [Risks and why]: The risk is very limited, and the code changed here doesn't impact Firefox, only DevTools, and only when the pref devtools.layoutview.enabled is set to true.
> [String/UUID change made/needed]: None
Comment on attachment 8813999 [details] [diff] [review]
1320010.patch

devtools fix for osx, take in aurora52

Thanks for clarifying the uplift request, Patrick!
Attachment #8813999 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
I've seen this issue on this bug in nightly 53.0a1 (2016-11-23) from windows 10, 64 bit.

This bug is verified now as fixed on latest nightly 53.0a1 .

Build Id :(20161127030208)

User agent : (Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0)
Status: RESOLVED → VERIFIED
status-firefox53: fixed → verified
Whiteboard: [testday-20161125]
needs rebasing for aurora
Flags: needinfo?(gl)
Flags: needinfo?(gl)

Comment 13

7 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/f3a55c57f637
status-firefox52: affected → fixed
I have reproduced this bug with Nightly 53.0a1 (2016-11-23) (64-bit)  on Windows 7, 64 Bit !

This bug's fix is verified with latest Aurora

Build ID    20161130004019
User Agent  Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
 [bugday-20161130]
status-firefox52: fixed → verified
You need to log in before you can comment on or make changes to this bug.