Closed Bug 1320189 Opened 3 years ago Closed 3 years ago

WebChannelMessageToContent listener does not forward errors finding a handler

Categories

(Toolkit :: General, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox53 --- fixed

People

(Reporter: vladikoff, Assigned: vladikoff)

References

()

Details

Attachments

(1 file)

Status: NEW → ASSIGNED
See Also: → 1255302
Mark, I don't think the reporting that we have in that file ever worked. I'm making a change to align it more with the format that Kit added earlier this year

Ref: https://bugzilla.mozilla.org/show_bug.cgi?id=1255302
Ref: https://github.com/mozilla/fxa-content-server/issues/3668
Updating the title - it turns out that unhandled exceptions in the listeners are reported to content, but errors generated by _sendErrorEventToContent are not. These latter ones are when we can't find a handler to use, or decline to use one due to a mismatched principal.
Summary: WebChannelMessageToContent listener does not forward errors to content → WebChannelMessageToContent listener does not forward errors finding a handler
Comment on attachment 8814248 [details]
Bugzilla #1320189 - Fix WebChannel error reporting for content errors

https://reviewboard.mozilla.org/r/95488/#review95600
Attachment #8814248 - Flags: review?(markh) → review+
Comment on attachment 8814248 [details]
Bugzilla #1320189 - Fix WebChannel error reporting for content errors

https://reviewboard.mozilla.org/r/95488/#review95600

There are some changes that need to be made to the remoteTroubleshoot, updating that and resubmitting for Try...
See Also: → 1253815
https://hg.mozilla.org/mozilla-central/rev/8144961dead7
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Duplicate of this bug: 1173830
You need to log in before you can comment on or make changes to this bug.