Web audio oscillator frequency.value returns incorrect value

RESOLVED DUPLICATE of bug 893020

Status

()

RESOLVED DUPLICATE of bug 893020
2 years ago
2 years ago

People

(Reporter: jack.schaedler, Unassigned)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_4) AppleWebKit/601.5.17 (KHTML, like Gecko) Version/9.1 Safari/601.5.17

Steps to reproduce:

I am attempting to read the current frequency value of an oscillator node.

The following code snippet will reproduce the issue:


var audioCtx = new (window.AudioContext || window.webkitAudioContext)();

var oscillator = audioCtx.createOscillator();
oscillator.type = 'square';
oscillator.frequency.value = 100;
oscillator.connect(audioCtx.destination);
oscillator.start();

oscillator.frequency.setValueAtTime(1000, audioCtx.currentTime + 1);
setTimeout(function() { console.log(oscillator.frequency.value); }, 3000);


Actual results:

The console prints out 100 for the value of the oscillator frequency.


Expected results:

The console prints out 1000 for the value of the oscillator frequency.

Updated

2 years ago
Component: Untriaged → Web Audio
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 893020
You need to log in before you can comment on or make changes to this bug.