[DateTimePicker] Hover state is not applied when hover with mouse over input field

RESOLVED DUPLICATE of bug 1309457

Status

()

RESOLVED DUPLICATE of bug 1309457
2 years ago
2 years ago

People

(Reporter: hani.yacoub, Unassigned)

Tracking

(Blocks: 1 bug)

53 Branch
Points:
---

Firefox Tracking Flags

(firefox53 affected)

Details

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Created attachment 8814397 [details]
test.html

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20161124030208

[Affected versions]:
Nightly 53.0a1

[Affected platforms]:
All platforms: Ubuntu 15.10, Mac OS X 10.11

[Steps to reproduce]:
1. Launch Nightly 53.0a1 with a new profile
2. Set "dom.forms.datetime" pref to True in about:config
3. Open attached html file
4. Hover with mouse over input field


[Expected result]:
Hover state should be applied on the input field.

[Actual result]:
Hover state is not applied.

[Note]
Works on:
- Windows 7  x 64 (Hover is applied only on top part of the input field)
- Windows 10 x 64
(Reporter)

Updated

2 years ago
Blocks: 1283381

Comment 1

2 years ago
Created attachment 8814412 [details]
Testcase showing hover state

:hover state is applied to the input field, but there's no styling of the :hover state. This is true for all mac input fields and I don't see why the time picker should behave differently here.

Comment 2

2 years ago
Created attachment 8814435 [details]
Screenshot showing :hover effect (attachment #8814412 [details])

Loading attachment #8814412 [details] in a nightly mac build one can see the :hover effect.
No longer blocks: 1323674
Blocks: 1323674
No longer blocks: 1283381

Updated

2 years ago
Component: XUL Widgets → Layout: Form Controls
Product: Toolkit → Core
Not sure I can recall correctly, but we did have a conclusion months ago.
We're not doing hover state styling, and will keep the way the other input types (numbers, text) behaves under different OSes.
Morpheus, was this documented somewhere in the UX spec?
(Apology again, but this is the best path i can think of)
Flags: needinfo?(mochen)
We proposed the design which followed Firefox guideline(https://firefoxux.github.io/StyleGuide/#/inputs). However, based on bug 1309457, the conclusion was to keep it consistent with all current input controls until Photon released. Please find the bug for more details and let me know if any questions, thank.
Flags: needinfo?(mochen)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1309457
You need to log in before you can comment on or make changes to this bug.