Closed Bug 1320330 Opened 8 years ago Closed 5 months ago

[Captive Portal] With Voice Over on, text from Captive Portal notification bar is not read

Categories

(Firefox :: Disability Access, defect)

Unspecified
macOS
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox53 --- affected

People

(Reporter: Ovidiu, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regressionwindow-wanted)

Attachments

(1 file)

Affected versions]:

Firefox Nightly 53.0a1 (2016-11-24)

[Affected platforms]:

Mac OS X 10.10 and Mac OS X 10.12


[Steps to reproduce]:

1. Make sure you are not connected to any Wi­Fi or wan. Start latest FF, with clean profile.
2. Search and try to connect to a Captive portal Wi­Fi network. (don't finish connecting to it:­> do not input u/p)
3. Activate Voice Over (System Preferences -> Accessibility -> Voice Over -> Enable Voice Over )
4. Focus the Captive Portal bar.

[Expected result]:

The text from the Captive Portal notification bar should be read.
 
[Actual result]:

The text from the Captive Portal notification bar is not read.
Blocks: 1202680
Is this a regression? This sounds like it's not specific to captive portal and would apply to all notification bars.
Component: General → Notifications and Alerts
Product: Firefox → Toolkit
Flags: needinfo?(ovidiu.boca)
I don't think this is a regression, I encounter the same problem with the out of date notification bar, but the captive portal notification bar has some improvements comparing with out of date: the close button is working and also the "Show login page" is also working. When I say working I am referring to the fact that the text from this two is read with Voice Over.
Flags: needinfo?(ovidiu.boca)
Component: Notifications and Alerts → Disability Access
Product: Toolkit → Firefox
Severity: normal → S3
Keywords: access

Removing unnecessary access keyword, since the bug is already in the Disability Access component and it would need to be triaged to set its severity

Severity: S3 → --

It looks like since this bug was reported the issue was resolved. While I do not have access to the Captive Portal to confirm that, the update dialog that was mentioned in comments as experiencing similar issues, is now being accessible with VoiceOver on macOS Sonoma 14.2.1 - tested with yesterday's Nightly 123.0a1 that sent a prompt to update. Screenshot of the announcement is attached.

I'll close this bug as WFM, but if the issue still exist, please do reopen it and, hopefully, we can get working STRs to debug.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: