the element hierarchy tag name in inspector is empty after different element selected

RESOLVED DUPLICATE of bug 1320182

Status

DevTools
Inspector
--
minor
RESOLVED DUPLICATE of bug 1320182
2 years ago
5 days ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

49 Branch
x86
Windows 10
regression

Firefox Tracking Flags

(firefox-esr45 unaffected, firefox50 wontfix, firefox51 wontfix, firefox52 fix-optional, firefox53 wontfix)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8814502 [details]
screenshot

+++ This bug was initially created as a clone of Bug #1320182 +++

The problem happens if HWA is enabled.
If the user selects a different element with the inspector, the bar with the element hierarchy can show text artifacts(empty).

Steps to reproduce:
0. Resize Browser to 1280*1024 if need
1. Open http://gridbyexample.com/examples/example4/
2. Right crick on black header bar and choose "Inspect Element"
3. Click empty area near [RETURN] button using Element picker

Actual Results:
The element hierarchy is scrolled as expected.
However, some tag name is empty.
See screenshot.
After mouse move over the missing tag name, it will display.

Regression Window:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=e3d409d10dea7c1c94630abf52e6e9245a77f448&tochange=5d2cb7fff024a1d3ed59ad2432882d158ce5ee91

Regressed by: Bug 1259812
(Reporter)

Comment 1

2 years ago
Created attachment 8814505 [details]
about:suppot

Updated

2 years ago
Blocks: 1263741
Whiteboard: [devtools-html] [triage]
(Reporter)

Comment 2

2 years ago
Changed importance from normal to minor because this is 2nd-3rd UI.
Severity: normal → minor

Updated

2 years ago
Flags: qe-verify+
Priority: -- → P3
QA Contact: petruta.rasa
Whiteboard: [devtools-html] [triage] → [reserve-html]
status-firefox50: affected → fix-optional
status-firefox51: affected → fix-optional
status-firefox50: fix-optional → wontfix
status-firefox51: fix-optional → wontfix
status-firefox52: affected → fix-optional
I think this should be closed as a duplicate of bug 1320182.
Bug 1320182 is about text artifacts appearing while this one is about bits of text disappearing, but I'm fairly certain the root cause is the same.

Anyway, in bug 1320182, I investigated a little bit and found that this seemed like a rendering issue due to DevTools using a -moz-element CSS background value.
(Reporter)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1320182
No longer blocks: 1263741
Flags: qe-verify+
Priority: P3 → --
QA Contact: petruta.rasa
Whiteboard: [reserve-html]

Updated

a year ago
No longer depends on: 1320182
Too late for a fix for 53, as we are in the last week of the 53 beta cycle.
status-firefox53: affected → wontfix

Updated

5 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.