Crash in conformance/extensions/webgl-draw-buffers-feedback-loop.html

RESOLVED FIXED in Firefox 51

Status

()

Core
Canvas: WebGL
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: vliu, Assigned: vliu)

Tracking

unspecified
mozilla53
Points:
---

Firefox Tracking Flags

(firefox51 fixed, firefox52 fixed, firefox53 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

a year ago
The crash happens when I run test on Khronos 2.0.1 webgl conformance test.
(Assignee)

Updated

a year ago
Assignee: nobody → vliu
(Assignee)

Comment 1

a year ago
Sorry for wrong information on Description. This test should belongs to Khronos 1.0.4 webgl conformance test.
(Assignee)

Comment 2

a year ago
Created attachment 8814773 [details] [diff] [review]
Add nullptr check for attach.

Hi Ethan,
Could you please have a review. Really thanks
Attachment #8814773 - Flags: review?(ethlin)
(Assignee)

Comment 3

a year ago
Created attachment 8815193 [details] [diff] [review]
Add nullptr check for attach.

Hi Ethan,
The proposed patch was as we discussed. Please have a review. Thanks.
Attachment #8815193 - Flags: review?(ethlin)
(Assignee)

Updated

a year ago
Attachment #8814773 - Attachment is obsolete: true
Attachment #8814773 - Flags: review?(ethlin)

Updated

a year ago
Attachment #8815193 - Flags: review?(ethlin) → review+
(Assignee)

Comment 4

a year ago
Comment on attachment 8815193 [details] [diff] [review]
Add nullptr check for attach.

Hi Jeff,
Since the patch was relative to spec, could you also help me to review it? Thanks
Attachment #8815193 - Flags: review?(jgilbert)
Comment on attachment 8815193 [details] [diff] [review]
Add nullptr check for attach.

Review of attachment 8815193 [details] [diff] [review]:
-----------------------------------------------------------------

You forgot FramebufferTextureLayer.
Attachment #8815193 - Flags: review?(jgilbert) → review-
(Assignee)

Comment 6

a year ago
Created attachment 8817067 [details] [diff] [review]
Add nullptr check for attach. r=jgilbert, ethlin

Hi Jeff,
Thanks for the review for the missing part. Could you review again for the attached atch? Thanks
Attachment #8817067 - Flags: review?(jgilbert)
(Assignee)

Updated

a year ago
Attachment #8815193 - Attachment is obsolete: true
Attachment #8817067 - Flags: review?(jgilbert) → review+
(Assignee)

Comment 7

a year ago
try result: https://treeherder.mozilla.org/#/jobs?repo=try&revision=ec0fee8fe00ae1aa001cf39f04ced98b11c31170

Comment 8

a year ago
Pushed by vliu@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/422dd1f29d6e
Add nullptr check for attach. r=jgilbert,

Comment 9

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/422dd1f29d6e
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox53: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
status-firefox51: --- → affected
status-firefox52: --- → affected
Comment on attachment 8817067 [details] [diff] [review]
Add nullptr check for attach. r=jgilbert, ethlin

Approval Request Comment
[Feature/Bug causing the regression]: webgl2
[User impact if declined]:
[Is this code covered by automated tests?]:
[Has the fix been verified in Nightly?]:
[Needs manual test from QE? If yes, steps to reproduce]: 
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]:
[Why is the change risky/not risky?]:
[String changes made/needed]:
Attachment #8817067 - Flags: approval-mozilla-beta?
Attachment #8817067 - Flags: approval-mozilla-aurora?
Comment on attachment 8817067 [details] [diff] [review]
Add nullptr check for attach. r=jgilbert, ethlin

WebGL2 related patch. Beta51+ & Aurora52+. Should be in 51 beta 8.
Attachment #8817067 - Flags: approval-mozilla-beta?
Attachment #8817067 - Flags: approval-mozilla-beta+
Attachment #8817067 - Flags: approval-mozilla-aurora?
Attachment #8817067 - Flags: approval-mozilla-aurora+

Comment 12

a year ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/37d7bbe99bc5
status-firefox52: affected → fixed

Comment 13

a year ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/7a137d063edc
status-firefox51: affected → fixed
You need to log in before you can comment on or make changes to this bug.