Note: There are a few cases of duplicates in user autocompletion which are being worked on.

51beta 2(cannot start the call.error message:-getUserMedia() error: NotFoundError)

RESOLVED INVALID

Status

()

Core
WebRTC: Audio/Video
P1
normal
Rank:
10
RESOLVED INVALID
8 months ago
8 months ago

People

(Reporter: pushanshu, Unassigned, NeedInfo)

Tracking

({regression})

49 Branch
x86_64
Windows 8
regression
Points:
---

Firefox Tracking Flags

(firefox50 affected, firefox51 affected, firefox52 affected, firefox53 affected)

Details

(Whiteboard: [testday-20161125])

(Reporter)

Description

8 months ago
User Agent: Mozilla/5.0 (Windows NT 6.2; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20161124073320

Steps to reproduce:

1. Go to https://webrtc.github.io/samples/src/content/peerconnection/pc1/ click Start and share you devices.
2. Click on "Call".
3. Click on "Hang Up".
4. Refresh the page and try to click on "Start".


Actual results:

(cannot start the call.error message:-getUserMedia() error: NotFoundError)


Expected results:

1. In the address bar the "i" starts to alternate with a red camera icon. 
2. Call starts and camera is capturing.
3. Call ends and camera stops capturing. 
4. Page is refreshed and you can click on "Start", camera starts capturing.
(Reporter)

Updated

8 months ago
OS: Unspecified → Windows 8
Priority: -- → P1
Hardware: Unspecified → x86

Updated

8 months ago
Component: Untriaged → WebRTC
Product: Firefox → Core

Comment 1

8 months ago
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2f3f8d6c0916d751337b253bc0b31f34eb8e0d8d&tochange=ff5d91a2420fe2e8697e310a029aa6a6cce1a984

Bug 802326

Updated

8 months ago
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Ever confirmed: true
Keywords: regression
OS: Windows 8 → All
Priority: P1 → --
Hardware: x86 → All
Version: 51 Branch → 49 Branch
Rank: 15
Priority: -- → P1
Rank: 15 → 10
OS: All → Windows 8
Hardware: All → x86_64
Whiteboard: [testday-20161125]
status-firefox50: --- → affected
status-firefox51: --- → affected
status-firefox52: --- → affected
status-firefox53: --- → affected

Updated

8 months ago
Blocks: 802326

Comment 2

8 months ago
Just to clear:

4. Refresh the page and try to click on "Start".

If I simply click refresh button in the URL bar, the "Start" button stays greyed out and can't be clicked.
So I assume "Refresh page" refers to a forced refresh by clicking refresh button while holding "Shift".

After doing a forced refresh it works for me on Mac with 52 just fine. No error.

Updated

8 months ago
Component: WebRTC → WebRTC: Audio/Video

Comment 3

8 months ago
Also works fine for me with 49.0.2 on Win 10.

Comment 4

8 months ago
Also verified with 53 on Win 10. No problem for me.

Could be some driver issue with some cameras?!

Could you please look up the camera make and model you were using?
Could also please check on about:support if you have Multiprocess on or off?
Flags: needinfo?(pushanshu25)

Comment 5

8 months ago
Clarification: I use a different STR to identify this issue.

When I perform the first step to reproduce, the error message "-getUserMedia() error: NotFoundError" appears and no authorization popup appears. Regression window see above. It can be reproduced using a clean profile, as well mozregression.
Ok, that's a different issue.  I suspect you don't ahve a camera, or don't have a mic, or it doesn't like something about one of them.

Can you try https://mozilla.github.io/webrtc-landing/gum_test.html, and try Audio, Video, and Audio+Video tests there?

The "can't click start" bug is a non-webrtc bug from long ago; the test page is assuming that .disabled is cleared on a  reload; we don't do that.
Flags: needinfo?(yfdyh000)

Comment 7

8 months ago
(In reply to Randell Jesup [:jesup] from comment #6)
> Ok, that's a different issue.  I suspect you don't ahve a camera, or don't
> have a mic, or it doesn't like something about one of them.

I have a microphone, as well as comment 1, I can get this popup before that regression window. However, it may indeed be a different issue.

> Can you try https://mozilla.github.io/webrtc-landing/gum_test.html, and try
> Audio, Video, and Audio+Video tests there?
> 
> The "can't click start" bug is a non-webrtc bug from long ago; the test page
> is assuming that .disabled is cleared on a  reload; we don't do that.

Results in 51.0b4 (64-bit) with clean profile:
Video: NotFoundError: The object can not be found here.
Audio: works.
Audio+Video: NotFoundError: The object can not be found here.
Flags: needinfo?(yfdyh000)
(In reply to YF (Yang) from comment #7)
> (In reply to Randell Jesup [:jesup] from comment #6)
> > Ok, that's a different issue.  I suspect you don't ahve a camera, or don't
> > have a mic, or it doesn't like something about one of them.
> 
> I have a microphone, as well as comment 1, I can get this popup before that
> regression window. However, it may indeed be a different issue.

We changed our implementation to match the spec, which requires failing audio+video requests if you don't have a video source.  Chrome doesn't do this.  The application is supposed to either check first, or after failure try again without video.  Yes, somewhat annoying, but that was the spec agreed to.

> Results in 51.0b4 (64-bit) with clean profile:
> Video: NotFoundError: The object can not be found here.
> Audio: works.
> Audio+Video: NotFoundError: The object can not be found here.

Right.  This says you don't have a camera -- or it doesn't like your camera.  From the comment above you said you had a microphone, but didn't answer about a camera; I assume you don't have one.  If so, this is INVALID.  Please reopen if this is incorrect, and if so try attaching a log done with MOZ_LOG=MediaManager:4,GetUserMedia:4

Thanks!
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.