Closed Bug 1320661 Opened 7 years ago Closed 7 years ago

Fails to link xul.dll without --enable-profiling on Windows

Categories

(Firefox Build System :: General, defect)

x86_64
Windows 10
defect
Not set
normal

Tracking

(firefox53 affected)

RESOLVED DUPLICATE of bug 1320312
Tracking Status
firefox53 --- affected

People

(Reporter: cyu, Unassigned)

References

Details

With latest m-c on Windows, local build fails to link xul.dll, reporting that in Telemetry.cpp, MozStackWalk symbol not found in KeyedStackCapturer::Capture().

It turns out that my local build config is --disable-profiling, optimized, non-debug one, but MOZ_ENABLE_PROFILER_SPS is enabled. This also means that bug 1225851 will start to fail once the patch enters beta. The MozStackWalk() call should be #ifdefed with MOZ_STACKWALKING because MOZ_ENABLE_PROFILER_SPS doesn't necessarily imply MOZ_STACKWALKING.
(In reply to Cervantes Yu [:cyu] [:cervantes] from comment #0)
> The
> MozStackWalk() call should be #ifdefed with MOZ_STACKWALKING because
> MOZ_ENABLE_PROFILER_SPS doesn't necessarily imply MOZ_STACKWALKING.

Does this actually make sense? As in, is there any point in running all this code if we don't actually have stacks to capture in telemetry?
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
(In reply to :Gijs Kruitbosch from comment #1)
> (In reply to Cervantes Yu [:cyu] [:cervantes] from comment #0)
> > The
> > MozStackWalk() call should be #ifdefed with MOZ_STACKWALKING because
> > MOZ_ENABLE_PROFILER_SPS doesn't necessarily imply MOZ_STACKWALKING.
> 
> Does this actually make sense? As in, is there any point in running all this
> code if we don't actually have stacks to capture in telemetry?

MozStackWalk() is one of the supported stack walking methods in SPS so this may make some sense (though this is confusing and the build config dependencies are a pitfall). Or we should just enable MOZ_STACKWALKING when telemetry is enabled as suggested in bug 1320312.
Summary: Fails to link xul.dll when without --enable-profiling on Windows → Fails to link xul.dll without --enable-profiling on Windows
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.