Closed Bug 1321396 Opened 3 years ago Closed 3 years ago

Allow skipped records by default for sync engines

Categories

(Firefox :: Sync, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 53
Tracking Status
firefox52 --- fixed
firefox53 --- fixed

People

(Reporter: tcsc, Assigned: tcsc)

References

Details

Attachments

(1 file)

If a record is too large to be uploaded to the server, currently most engines fail to sync instead of skipping that record. This is overly conservative, and instead we should only fail in cases where a partial sync is worse than no sync at all (like bookmarks, clients, prefs -- since it's a single record, etc.)

Patch incoming.
Comment on attachment 8815881 [details]
Bug 1321396 - Skip oversized records without aborting the sync by default in sync engines.

https://reviewboard.mozilla.org/r/96678/#review96910
Attachment #8815881 - Flags: review?(markh) → review+
Pushed by tchiovoloni@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/16a80745ac45
Skip oversized records without aborting the sync by default in sync engines. r=markh
https://hg.mozilla.org/mozilla-central/rev/16a80745ac45
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Comment on attachment 8815881 [details]
Bug 1321396 - Skip oversized records without aborting the sync by default in sync engines.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1253051
[User impact if declined]: Users with massive records to sync will fail to sync at all
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: yes, and Aurora
[Needs manual test from QE? If yes, steps to reproduce]: No 
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: Low risk.
[Why is the change risky/not risky?]: limited to sync, has been on central for some time
[String changes made/needed]: None

Sorry for the delay here - this slipped off our radar and the request should have been made earlier.
Attachment #8815881 - Flags: approval-mozilla-beta?
Comment on attachment 8815881 [details]
Bug 1321396 - Skip oversized records without aborting the sync by default in sync engines.

most sync engines allow skipping big records rather than failing, beta52+, should be in b3
Attachment #8815881 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Duplicate of this bug: 1320772
You need to log in before you can comment on or make changes to this bug.