Occurences of uninitialized variables being used before being set (in content/html/style and layout/html/style)

RESOLVED DUPLICATE of bug 59652

Status

()

Core
DOM: CSS Object Model
RESOLVED DUPLICATE of bug 59652
17 years ago
15 years ago

People

(Reporter: Aleksey Nogin, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
This bug is just for the "xxx might be used uninitialized" warnings in various
source files in content/html/style and layout/html/style directories (hopefully
this is the right component for them).
Currently (http://tinderbox.mozilla.org/SeaMonkey/warn1016552220.1515.html -
Tue, 19 Mar 2002 10:37 EST) TBox shows the following warnings:

content/html/style/src/nsCSSParser.cpp:2865
 `enum nsCSSUnit units' might be used uninitialized in this function

content/html/style/src/nsRuleNode.cpp:1843
 `enum nsSystemFontID sysID' might be used uninitialized in this function

content/html/style/src/nsRuleNode.cpp:4260
 `enum nsStyleContentType type' might be used uninitialized in this function

layout/html/style/src/nsCSSRendering.cpp:1754
 `int shrinkage' might be used uninitialized in this function
 `int startRadius' might be used uninitialized in this function
 `int endRadius' might be used uninitialized in this function

layout/html/style/src/nsCSSRendering.cpp:257
 `int outsideEdge' might be used uninitialized in this function
 `int insideEdge' might be used uninitialized in this function
 `int outsideTL' might be used uninitialized in this function
 `int insideTL' might be used uninitialized in this function
 `int outsideBR' might be used uninitialized in this function

layout/html/style/src/nsCSSRendering.cpp:258
 `int insideBR' might be used uninitialized in this function
(Reporter)

Comment 1

17 years ago
Bug 59652 is the meta-bug tracking the fight against these (potentially very
nasty) warnings; bug 59675 is for warning in layout and bug 126457 is for
warnings in content.

P.S. There is also

content/shared/src/nsStyleUtil.cpp:415
 `PRInt32 * column' might be used uninitialized in this function

Blocks: 59652, 59675, 126457

Updated

16 years ago
Summary: Occurances of uninitialized variables being used before being set (in content/html/style and layout/html/style) → Occurences of uninitialized variables being used before being set (in content/html/style and layout/html/style)
(Reporter)

Updated

16 years ago
Depends on: 155539
Mass-reassigning bugs to dom_bugs@netscape.com
Assignee: jst → dom_bugs
(Reporter)

Updated

15 years ago
Depends on: 208868
No longer blocks: 59652
No longer depends on: 155539
No longer depends on: 208868
(In reply to comment #1)
> Bug 59652 is the meta-bug tracking the fight against these (potentially very

Resolving as Duplicate !

> content/shared/src/nsStyleUtil.cpp:415
>  `PRInt32 * column' might be used uninitialized in this function

This one was actually listed in bug 126457 comment 0 :->
Anyway, this warning has disappeared by now :-)

*** This bug has been marked as a duplicate of 59652 ***
No longer blocks: 59675, 126457, 179819
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.