"Get Map" does not work via keyboard

RESOLVED WORKSFORME

Status

P2
normal
RESOLVED WORKSFORME
17 years ago
13 years ago

People

(Reporter: nbaca, Assigned: ssu0262)

Tracking

({access})

Trunk
mozilla1.0
All
Windows ME
access
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ADT3])

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Trunk build 2002-03-18: WinMe

Overview: Tab to the Get Map button, press Enter (also tried the space bar) and 
nothing happens.

Steps to reproduce:
1. Create an address card with a valid address (street address, city, state, zip 
code).
2. Tab into the card pane and continue tabbing until the Get Map button is 
highlighted.
3. Once the Get Map button is highlighted press Enter (or space bar)

Actual Results: Nothing happens
Expected Results: A new browser window should appear showing a map of the 
selected card.
(Reporter)

Comment 1

17 years ago
Marking nsbeta1 because this is important for accessibility reasons. Pressing 
Enter (or space) on the Get Map button should perform the same function as 
clicking with a mouse.

Also adding access to keywords.

This problem occurs on all platforms.
Assignee: racham → sspitzer
Keywords: access, nsbeta1
Hardware: PC → All
(Reporter)

Comment 2

17 years ago
Removed "Quick Search" from Summary since this problem is a general problem, not
specific to quick search.
Summary: Quick Search: "Get Map" does not work via keyboard → "Get Map" does not work via keyboard
(Reporter)

Updated

17 years ago
Blocks: 128661
(Reporter)

Updated

17 years ago
Blocks: 132468

Comment 3

17 years ago
Discussed at Mail News bug mtg with Engineering, QA Mktng, and PjM.  Decisions
was to plus this bug.
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P2
Target Milestone: --- → mozilla1.0

Comment 4

17 years ago
reassigning to ssu.
Assignee: sspitzer → ssu

Comment 5

17 years ago
Discussed in Mail News bug meeting.  Decided to ADT3 this bug.
Whiteboard: [ADT3]

Comment 6

17 years ago
Changing nsbeta1+ [adt3] bugs to nsbeta1- on behalf of the adt.  If you have any
questions about this, please email adt@netscape.com.  You can search for
"changing adt3 bugs" to quickly find and delete these bug mails.
Keywords: nsbeta1-

Comment 7

17 years ago
Changing nsbeta1+ [adt3] bugs to nsbeta1- on behalf of the adt.  If you have any
questions about this, please email adt@netscape.com.  You can search for
"changing adt3 bugs" to quickly find and delete these bug mails.
Keywords: nsbeta1+
(Assignee)

Comment 8

17 years ago
Created attachment 83085 [details] [diff] [review]
patch v1.0

Comment 9

17 years ago
Comment on attachment 83085 [details] [diff] [review]
patch v1.0

r=bhuvan
Attachment #83085 - Flags: review+

Comment 10

17 years ago
Comment on attachment 83085 [details] [diff] [review]
patch v1.0

sr=mscott
Attachment #83085 - Flags: superreview+
(Assignee)

Comment 11

17 years ago
patch checked into trunk only.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

16 years ago
Trunk build 2002-07-16: WinMe, Linux RH 7.1 - ok

Trunk build 2002-07-16: Mac 10.1.3 - fails
Reopening since pressing the Tab key completely skips over the Get Map button on 
Mac X.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 13

16 years ago
Marking nsbeta1 for accessibility reasons.
Keywords: nsbeta1- → nsbeta1
(Reporter)

Comment 14

16 years ago
Trunk build 2002-12-23: Winme - Worksforme
Trunk build 2002-12-20: Linux RH 8 - Worksforme
Marking Worksforme

Bug# 186701 covers a general accessibility problem on the Mac (i.e. Tab,
Shift+Tab is broken)
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 15

16 years ago
Trunk build 2003-04-24: Mac 10.1.5
Problem: 
- Modern skin, tab and it skips the email link and goes to "Get Map" button and
has focus and works.
- Classic skin, tab and it skips the email link but the "Get Map" button doesn't
appear to have focus, but it does because after pressing Enter it launches the
browser and dispays a mapquest map.

Trunk build 2003-04-23: WinXP - ok.
Trunk build 2003-04-24: Linux RH 8 - ok.

Reopening due to Mac issue.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 16

16 years ago
adt: nsbeta1-
Keywords: nsbeta1 → nsbeta1-
Product: Browser → Seamonkey

Comment 17

14 years ago
If it is reopened due to MacOS problems, shouldn't target OS be changed to
MacOS? (plus target milestone is way overdue)

Comment 18

13 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050917
SeaMonkey/1.1a

Updated

13 years ago
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.