Arial Black is not Arial 900

RESOLVED DUPLICATE of bug 644385

Status

()

RESOLVED DUPLICATE of bug 644385
2 years ago
a year ago

People

(Reporter: antoine.leverve.ext, Unassigned)

Tracking

({fonts})

50 Branch
x86_64
Windows 7
fonts
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; rv:11.0) like Gecko

Steps to reproduce:

I used the Arial Black font


Actual results:

The display was incorrect, looking not bold at all compared to IE or CR.

But if I use instead Arial with a 900 font-weight and that worked! I am doing that now because my boss wants a fix, but that's dirty, Arial Black is in the list of recommended web fonts from w3school.




Expected results:

Arial Black should display the same as Arial with a 900 font-weight
(Reporter)

Updated

2 years ago
Depends on: 644385
(Reporter)

Updated

2 years ago
Keywords: fonts
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
"Arial Black" is recognized as a font family name under the legacy GDI model, where families were limited to four faces, but is categorized as a face within the larger "Arial" family under DirectWrite. See John Daggett's explanations in bug 644385.

So you should use the pattern suggested there, with CSS properties such as

  font-family: Arial Black, Arial, sans-serif;
  font-weight: 900;

which selects the desired face under both models.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 644385
Moving from Core::Untriaged to Core::General https://bugzilla.mozilla.org/show_bug.cgi?id=1407598
Component: Untriaged → General
You need to log in before you can comment on or make changes to this bug.