Closed Bug 1321568 Opened 3 years ago Closed 3 years ago

Crash in java.lang.UnsupportedOperationException: at org.mozilla.gecko.prompts.Prompt.addInputValues(Prompt.java)

Categories

(Core :: Widget: Android, defect, critical)

Unspecified
Android
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla53
Tracking Status
firefox50 --- unaffected
firefox51 --- unaffected
firefox52 --- unaffected
firefox53 --- fixed

People

(Reporter: marcia, Assigned: jchen)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-52a98e2d-dc6a-4135-bc42-b9bd22161201.
=============================================================

Seen while viewing Nightly crash stats - #3 crash on nightly that had no bug filed: http://bit.ly/2gYTNWb. Looks as if all crashes are on Build 20161130030206 so far. Uptime range indicates it is a startup crash.
I'm getting this crash and willing to help debug...

I suspect it's related to LastPass.  I have the LastPass add-on installed, and changed my master password recently from a different web browser.  It's now prompting me with "LastPass: Invalid password!" shortly after the browser starts. When I try to log back into LastPass with the correct password, I get this crash immediately when hitting OK on the login dialog.
I experience this bug for several days two. The steps to reproduce are:
1) Open Fennec Nightly.
2) Have master password set up.
3) Go to any site with login credentials stored for.
4) When the master password dialog opens, do whatever you want.

In step 4, either you enter the password or tap Cancel, the dialog will appear for the second time, than Nightly freezes and crash. No add-on like LastPass installed, only uBlock origin, but happened to me with Adblock plus too. Also not it is not a startup bug. I have tried to wait for few minutes before going to a site asking for password, but the result was the same.
I'm also getting this crash, after entering http auth credentials. STR:
1. Go to https://staktrace.com/apps/bugmash/dashboard.php
2. Enter a username and password (anything will do)
3. Hit ok
4. Crash
I see the same as comment 2 describes, without any of the add-ons installed.
Problem is still around with today's build:

https://crash-stats.mozilla.com/report/index/4a5b8c6a-2386-4493-a846-e32de2161207
Jim, looks like a regression from your recent change.
Blocks: 1319496
Flags: needinfo?(nchen)
Keywords: regression
ok, so LastPass is only involved because it's using an input control, and any old input control triggers it, looks like.
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Flags: needinfo?(nchen)
Correctly handle null values and CharSequence values (that are not
Strings) returned by prompt inputs. r=me for trivial patch.
Attachment #8817447 - Flags: review+
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c6face1d7183
Handle null and CharSequence prompt values; r=me
https://hg.mozilla.org/mozilla-central/rev/c6face1d7183
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
I am glad to confirm this problem fixed in

appid	{aa3c5121-dab2-40e2-81ca-7ea25febc110}
apptype	mobile/android
vendor	Mozilla
name	Fennec
version	53.0a1
appbuildid	20161210030206
platformbuildid	20161210030206
geckobuildid	20161210030206
platformversion	53.0a1
geckoversion	53.0a1

both for entering a master password and for canceling out of the dialog.
Ditto, confirming fixed for me, too.
Status: RESOLVED → VERIFIED
Further confirmation: this crash occurred 28 times in Nightly 20161209030212 but hasn't appeared since.
You need to log in before you can comment on or make changes to this bug.