Closed Bug 1321586 Opened 3 years ago Closed 2 years ago

How to go back to previous emoji set

Categories

(Core :: Layout: Text and Fonts, defect, P3)

50 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1032671

People

(Reporter: ajstewart426, Unassigned)

Details

Attachments

(1 file)

Attached image firefox-reactions.png
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161124113440

Steps to reproduce:

I recently updated to Firefox 50 on Fedora 24


Actual results:

My GitHub reaction emoji drastically changed. They look much worse than before. Attached is a screenshot of what they look like now.


Expected results:

I noticed that Firefox made the switch to EmojiOne with Firefox 50. However, the emoji I'm seeing don't look like EmojiOne at all. Is there a way to switch it back to use the previous emoji set?
At least the thumbs up/down emoji in the screenshot are EmojiOne emoji (from the 2.x branch), see http://emojipedia.org/thumbs-up-sign/

Did you expect e.g. Segoe UI Emoji like http://www.istartedsomething.com/uploads/emojisegoe.html ?

As far as I can see, bug 1231701 added EmojiOne for use on Windows XP-7 and Linux (at least where emoji fonts are missing).
> Did you expect e.g. Segoe UI Emoji

Ah, so that's what it's called. Yes, that's what it previously looked like.

> (at least where emoji fonts are missing)

Does that mean it checks to see if a particular emoji is defined, and if not it uses EmojiOne? That would explain why some of the emoji (smiley face) look like the system emoji and others (thumbs up) look like EmojiOne.

Is there any way to go back to Segoe UI Emoji? Aside from downgrading FireFox or switching to Chrome :P
(In reply to ajstewart426 from comment #2)
> Is there any way to go back to Segoe UI Emoji?
Your best chances are to install an updated version of that font.
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161104212021

I tested this bug on FEDORA 23 X64, using Firefox 50.0 and I managed to reproduce it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Product: Firefox → Core
Component: Untriaged → Layout: Text
> Your best chances are to install an updated version of that font.

How do I do this? Is there a dnf package that I can install?
Reproduced in LMDE 2 with Firefox 52.0.2.
Priority: -- → P3
Firefox have font.name-list.emoji preference now by bug 1032671 from 59, so you can change emoji font by it.

feel free to reopen this when yon cannot resolve this by font.name-list.emoji on 59+.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1032671
You need to log in before you can comment on or make changes to this bug.