Closed Bug 1321587 Opened 3 years ago Closed 3 years ago

Update to WebRender 996f2ba9da276ac813a6c0dec67339769f1264db

Categories

(Core :: Graphics: WebRender, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla54

People

(Reporter: nical, Assigned: nical)

References

(Depends on 1 open bug)

Details

No description provided.
Assignee: nobody → nical.bugzilla
Pushed by nsilva@mozilla.com:
https://hg.mozilla.org/projects/graphics/rev/1a3356dc409f
WebRender update. r=gfx?
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Pushed by mchang@mozilla.com:
https://hg.mozilla.org/projects/graphics/rev/26f58f1fdd02
Update README.webrender with the latest webrender commit. DONTBUILD
This update seemed to make that gfx branch did not work on windows. On my Win 10 pc, I got the following panic log. Call to glPushGroupMarkerEXT was added by this bug.

> thread '<unnamed>' panicked at 'Could not find symbol "glPushGroupMarkerEXT" in Opengl32.dll or wglGetProcAddress', C:\quantum_gfx_src_1\graphics\gfx\webrender_bindings\src\bindings.rs:154
Flags: needinfo?(nical.bugzilla)
(In reply to Pulsebot from comment #1)
> Pushed by nsilva@mozilla.com:
> https://hg.mozilla.org/projects/graphics/rev/1a3356dc409f
> WebRender update. r=gfx?

When I locally backed out 1a3356dc409f, the problem on windows was addressed.
Call to "glPushGroupMarkerEXT" seems to be added  by https://github.com/servo/webrender/pull/604
On win pc that did not caused comment 3 also panicked in another place.

thread '<unnamed>' panicked at 'called `Option::unwrap()` on a `None` value', ../src/libcore\option.rs:323
stack backtrace:
   0:     0x7ff9a5b46cb2 - std::panicking::default_hook::{{closure}}
                        at C:\bot\slave\nightly-dist-rustc-win-msvc-64\build\src\libstd\panicking.rs:252
   1:     0x7ff9a5b45678 - std::panicking::rust_panic_with_hook
                        at C:\bot\slave\nightly-dist-rustc-win-msvc-64\build\src\libstd\panicking.rs:451
   2:     0x7ff9a5b4a02e - std::panicking::begin_panic<collections::string::String>
                        at C:\bot\slave\nightly-dist-rustc-win-msvc-64\build\src\libstd\panicking.rs:413
   3:     0x7ff9a5b49fcb - std::panicking::begin_panic_fmt
                        at C:\bot\slave\nightly-dist-rustc-win-msvc-64\build\src\libstd\panicking.rs:397
   4:     0x7ff9a5b54859 - core::panicking::panic_fmt
                        at C:\bot\slave\nightly-dist-rustc-win-msvc-64\build\src\libcore\panicking.rs:61
   5:     0x7ff9a5b563d8 - core::panicking::panic
                        at C:\bot\slave\nightly-dist-rustc-win-msvc-64\build\src\libcore\panicking.rs:49
   6:     0x7ff9a5afb3fc - webrender::tiling::FrameBuilder::build
                        at C:\quantum_gfx_src_1\graphics\gfx\webrender\src\tiling.rs:2936
Flags: needinfo?(kvark)
Blocks: webrender
WR code handles the case of `glPushGroupMarkerEXT` not being available, so what we need to do is make some sort of a whitelist for extensions in the WR binding crate, having those extensions that are valid to be NULL.
Flags: needinfo?(nical.bugzilla)
Flags: needinfo?(kvark)
Depends on: 1322949
(In reply to Sotaro Ikeda [:sotaro] from comment #6)
> On win pc that did not caused comment 3 also panicked in another place.
> 
> thread '<unnamed>' panicked at 'called `Option::unwrap()` on a `None`
> value', ../src/libcore\option.rs:323
> stack backtrace:
>    0:     0x7ff9a5b46cb2 - std::panicking::default_hook::{{closure}}
>                         at

I looked into it. It was caused by a change of gfx/webrender_bindings/src/bindings.rs by https://hg.mozilla.org/projects/graphics/rev/1a3356dc409f
Depends on: 1322956
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.