Closed Bug 1321750 Opened 3 years ago Closed 3 years ago

Got gcc: error: unrecognized command line option ‘-fdiagnostics-color’

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox53 fixed)

RESOLVED FIXED
mozilla53
Tracking Status
firefox53 --- fixed

People

(Reporter: JamesCheng, Unassigned)

References

Details

Attachments

(1 file)

I met this error with the following condition.
My host compiler is < 4.9 and the target compiler is >= 4.9

I should remove 

http://searchfox.org/mozilla-central/rev/0c055ccbcf96846044fc9a71421bd9b7978686f7/build/moz.configure/toolchain.configure#896-900

to make it pass the compiling.
I think the easy way out here (as in, landable) is to remove HOST_CFLAGS/HOST_CXXFLAGS from https://dxr.mozilla.org/mozilla-central/rev/9b8bf5feb0b52aa4b03aa5fa3d4f0727b2974663/config/config.mk#357-358

We don't have much host code, and we can live with not having colors for them. Until we fix the asymmetry between host and target compilers in a global way.
(note that even funnier setups exist and work for android, where the target and host compilers are different compilers altogether (one being gcc and the other clang), and that are equally broken since the color flag for both compilers is different)
Comment on attachment 8816504 [details]
Bug 1321750 - Remove automatic color flags from HOST_CFLAGS, HOST_CXXFLAGS;

https://reviewboard.mozilla.org/r/97234/#review97572

> Until we have better distinction between host and target compilers
> in configure

configure is actually the only place where host and target compilers are properly distinguished. The problem is the rest of the build system, including old-configure.
Attachment #8816504 - Flags: review?(mh+mozilla) → review+
Pushed by gszorc@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a8e20bf36959
Remove automatic color flags from HOST_CFLAGS, HOST_CXXFLAGS; r=glandium
https://hg.mozilla.org/mozilla-central/rev/a8e20bf36959
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.