Memory leak of 16 bytes from 1 block allocated in xptiInterfaceEntry::GetInterfaceInfo

VERIFIED DUPLICATE of bug 99143

Status

()

VERIFIED DUPLICATE of bug 99143
17 years ago
16 years ago

People

(Reporter: stephend, Assigned: jband_mozilla)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Build ID: Latest win32 trunk pulled at 5:30 pm 3-19-2002, Windows 2000 under 
Purify.

Steps to Reproduce:

Just loading a default homepage of http://home.netscape.com yields:

[W] MLK: Memory leak of 16 bytes from 1 block allocated in 
xptiInterfaceEntry::GetInterfaceInfo(xptiInterfaceInfo * *)
    Distribution of leaked blocks
    Allocation location
    new(UINT)      [MSVCRT.DLL]
    xptiInterfaceEntry::GetInterfaceInfo(xptiInterfaceInfo * *) 
[xptiInterfaceInfo.cpp:735]
    
        if(!mInfo)
        {
 =>         mInfo = new xptiInterfaceInfo(this);
            if(!mInfo)
            {
                *info = nsnull;
    ???            [ip=0x09da68c0]
    EntryToInfo    [xptiInterfaceInfoManager.cpp:1644]
            return NS_ERROR_FAILURE;
        }
    
 =>     rv = entry->GetInterfaceInfo(&info);
        if(NS_FAILED(rv))
            return rv;
    
    xptiInterfaceInfoManager::GetInfoForName(char const*,nsIInterfaceInfo * *) 
[xptiInterfaceInfoManager.cpp:1680]
        xptiInterfaceEntry* entry =
            PL_DHASH_ENTRY_IS_FREE(hashEntry) ? nsnull : hashEntry->value;
    
 =>     return EntryToInfo(entry, _retval);
    }
    
    /* nsIIDPtr getIIDForName (in string name); */
    ???            [ip=0x04490c20]
    nsXPCComponents_Interfaces::NewResolve(nsIXPConnectWrappedNative 
*,JSContext *,JSObject *,long,UINT,JSObject * *,int *) [xpccomponents.cpp:231]
           name[0] != '{') // we only allow interfaces by name here
        {
            nsCOMPtr<nsIInterfaceInfo> info;
 =>         mManager->GetInfoForName(name, getter_AddRefs(info));
            if(!info)
                return NS_OK;
    
    XPC_WN_Helper_NewResolve [xpcwrappednativejsops.cpp:904]
                    oldResolvingWrapper = ccx.SetResolvingWrapper(wrapper);
        
                rv = si->GetCallback()->NewResolve(wrapper, cx, obj, idval, 
flags,
     =>                                              &obj2FromScriptable, 
&retval);
        
                if(allowPropMods)
                    (void)ccx.SetResolvingWrapper(oldResolvingWrapper);
    js_LookupProperty [jsobj.c:2228]
    js_GetProperty [jsobj.c:2432]
    js_Interpret   [jsinterp.c:2576]
    js_Execute     [jsinterp.c:968]
    JS_ExecuteScript [jsapi.c:3256]
    ???            [ip=0x046dc208]
    mozJSComponentLoader::GlobalForLocation(char const*,nsIFile *) 
[mozJSComponentLoader.cpp:1202]
    mozJSComponentLoader::ModuleForLocation(char const*,nsIFile *) 
[mozJSComponentLoader.cpp:1000]
    mozJSComponentLoader::AttemptRegistration(nsIFile *,int) 
[mozJSComponentLoader.cpp:834]
    mozJSComponentLoader::AutoRegisterComponent(int,nsIFile *,int *) 
[mozJSComponentLoader.cpp:760]
    mozJSComponentLoader::RegisterComponentsInDir(int,nsIFile *) 
[mozJSComponentLoader.cpp:590]
    mozJSComponentLoader::AutoRegisterComponents(int,nsIFile *) 
[mozJSComponentLoader.cpp:545]
(Assignee)

Comment 1

17 years ago
dup. Same entrained object. But now allocated in a different place. 

*** This bug has been marked as a duplicate of 99143 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.