Add getting and setting of cookie permissions for origin to WebExtensions

RESOLVED DUPLICATE of bug 1291841

Status

RESOLVED DUPLICATE of bug 1291841
2 years ago
5 months ago

People

(Reporter: tlschilling, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160922113459

Steps to reproduce:

Please add the ability to get and set the cookie permissions (accept/deny/accept for session) for an origin (URL) to WebExtensions.  Perhaps add to the browser.cookies namespace?


Actual results:

For XUL/XPCOM, this functionality is found in nsIPermissionManager.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1291841

Updated

5 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.