html source viewer redownloads the page, the source you see is NOT the source of the page you are viewing.

VERIFIED DUPLICATE of bug 55583

Status

SeaMonkey
Composer
--
major
VERIFIED DUPLICATE of bug 55583
16 years ago
13 years ago

People

(Reporter: Tyler Ward, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.9) Gecko/20020310
BuildID:    2002031005


The html source viewer very obviously re downloads the html source of a a page
when you hit "view source" It doesn't even resend the post or get data, so on
dynamic pages the source you see can have no relationship to the page you are
actually viewing.

Mozilla should cache the source of the current page and deliver that up as the
source when you hit view source. That way you are actually seeing the source for
the page you're viewing. OR, at the very least it should send in the post or get
form data as if you had hit the refresh button so that there is a decent chance
that you can get the same page. 



Reproducible: Always
Steps to Reproduce:
1.Go to a dynamic web page.
2.mess with it.
3.view the source, and voilla, the source is the source for the original (un
messed with) page, not the page you're viewing.

Actual Results:  source was source for baseline page, the one that is displayed
if you don't send in any form variables. Despite the fact that I was clearly
viewing a version of the dynamic page that is generated when form data is sent in.

Expected Results:  It should have showed me the actual source to the actual page
I'm looking at, not the source to the baseline page at the same URL.

This is a VERY severe problem. It makes Mozilla useless for debugging dynamic
pages of any sort. There is no reason whatsoever why the browser should
reconnect to a server to get source. The source is very small, just cache it.
This should speed up source viewing as well.

*** This bug has been marked as a duplicate of 55583 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 3

15 years ago
reassign in case bugs are reopened
Assignee: syd → composer
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.