Closed Bug 1322686 Opened 5 years ago Closed 5 years ago

Gdk-ERROR The program 'firefox' received an X Window System error.

Categories

(Core :: Widget: Gtk, defect)

50 Branch
x86_64
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1271100

People

(Reporter: th.sievers, Unassigned)

Details

(Keywords: crash)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161130210124

Steps to reproduce:

start game at www.myfreefarm.de
after 10 seconds crash


Actual results:

The error was 'BadAccess (attempt to access private resource denied)'.
  (Details: serial 8731 error_code 10 request_code 130 (MIT-SHM) minor_code 1)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Trace/Breakpoint ausgelöst (Speicherabzug geschrieben)
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Severity: normal → critical
Keywords: crash
Thomas, can you help me by answering some questions and perhaps helping debug?:

* are you using a mozilla.org build of Firefox or one provided by your distribution? If it's a distribution, please provide details about the OS and OS version
* When it crashes, do you see the Mozilla crash reporter? If so can you use about:crashes to find the crash report ID and paste it into this bug?
* can you run Firefox with GDK_SYNCHRONIZE set? If so, getting the crash report details from that build would be most helpful.
* Is there any way to play this game without an account?  Or can you determine whether this game is implemented in Flash or using native HTML?
** If it's Flash, what version of Flash are you running (you can check in about:plugins). You should have 11.2.202.644 for Linux, unless you're using an Adobe Flash beta build.
Flags: needinfo?(th.sievers)
Hello Benjamin

I´m a normal user

- Firefox is from distribution
- I use manjaro 16.10, it is based on arch linux
- I don´t get a crash reporter after crash
- Sorry, but how can I run Firefox with GDK_SYNCHRONIZE set? I don´t know how to do this
- You need an account to play. I think the game do not need flash
. Yes flash is Version 11.2.202.644

best regards, Thomas
Hello Benjamin

some more info if needed

- I use Gnome Desktop
- with Firefox 49 and before was no problem
Hello Thomas,
I can't reproduce the issue on Ubuntu 16.04 using either Release 50 or Nightly 53. 

The system variable Benjamin is taking about can be set with $ export GDK_SYNCHRONIZE=1 . Try running FF with this variable set.
Also, could you perhaps try downloading an official firefox build and see if you can reproduce the crash with it? Most likely, you will have a crash report to go with reproducing the issue, which will be very helpful.
Hello Adrian

after the command $ export GDK_SYNCHRONIZE=1 
I´ve started the game and played without a crash
Thanks a lot
(In reply to Thomas Sievers from comment #5)
> Hello Adrian
> 
> after the command $ export GDK_SYNCHRONIZE=1 
> I´ve started the game and played without a crash
> Thanks a lot
Benjamin, where should we go from here? I'm not sure exactly how to interpret the fact that FF works fine with the GDK_SYNCHRONIZE=1 in terms on follow-up.

Also, Thomas could you please find some time and confirm if you can reproduce the crash without the GDK_SYNCHRONIZE=1 on a stock firefox build? I have a wild guess that you won't be able to.
Flags: needinfo?(benjamin)
I'm moving this into the probably-correct component. There is likely some sort of race condition, but I expect that unless we can come up with reliable STR on another machine, we won't be able to make headway. Let's keep it open for a few weeks to see if reliable STR can be extracted.
Component: Untriaged → Widget: Gtk
Flags: needinfo?(benjamin)
Product: Firefox → Core
Adding test account credentials for www.myfreefarm.de:
u: adrian_00001
p: adrian1234
Hello Adrian

after the command $ export GDK_SYNCHRONIZE=0
have updated Firefox to 50.1.0 from manjaro
and now I can play without crash
seems to be fixed
thank you
Resolving WFM as per Comment 9: problem got fixed by updating from 50.0 to 50.1 Manjaro.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(th.sievers)
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1271100
You need to log in before you can comment on or make changes to this bug.