Display message about migration undo on about:newtab in addition to about:home

VERIFIED FIXED in Firefox 51

Status

()

defect
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: Gijs, Assigned: Gijs)

Tracking

(Blocks 1 bug)

unspecified
Firefox 53
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox51 verified, firefox52 verified, firefox53 verified)

Details

Attachments

(1 attachment)

Assignee

Description

3 years ago
(keeping about:home because that seems simplest for future funnelcakes etc. - the code will likely end up all being wiped in one go at some point anyway.)
Comment hidden (mozreview-request)
Assignee

Updated

3 years ago
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED

Comment 2

3 years ago
mozreview-review
Comment on attachment 8818953 [details]
Bug 1322730 - display undo migration message on about:newtab,

https://reviewboard.mozilla.org/r/98862/#review102354

::: browser/components/migration/AutoMigrate.jsm:322
(Diff revision 1)
>        return;
>      }
>  
>      let win = target.ownerGlobal;
>      let notificationBox = win.gBrowser.getNotificationBox(target);
> -    if (!notificationBox || notificationBox.getNotificationWithValue("abouthome-automigration-undo")) {
> +    if (!notificationBox || notificationBox.getNotificationWithValue(kNotificationId)) {

Constants, what are they good for? :)
Attachment #8818953 - Flags: review?(dolske) → review+
Comment hidden (mozreview-request)

Comment 4

3 years ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/9647d2c82af4
display undo migration message on about:newtab, r=Dolske

Comment 5

3 years ago
Backout by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/641dd38a2315
Backed out changeset 9647d2c82af4 for eslint failures. r=backout
Comment hidden (mozreview-request)

Comment 7

3 years ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/7e31694292a4
display undo migration message on about:newtab, r=Dolske

Comment 8

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7e31694292a4
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Assignee

Comment 9

3 years ago
Comment on attachment 8818953 [details]
Bug 1322730 - display undo migration message on about:newtab,

Approval Request Comment
[Feature/Bug causing the regression]: funnelcake for bug 1322718
[User impact if declined]: impact to the funnelcake
[Is this code covered by automated tests?]: yes!
[Has the fix been verified in Nightly?]: no, because it's behind a pref
[Needs manual test from QE? If yes, steps to reproduce]: yes, but we'll need a custom build. Verification is easy: on the custom build, users should get a notification about the import on about:newtab .
[List of other uplifts needed for the feature/fix]: the other deps for bug 1322718 are related, but I don't think this particular bug will require anything else.
[Is the change risky?]: No.
[Why is the change risky/not risky?]:  it's completely behind a pref (the automigration one) so will only affect the funnelcake.
[String changes made/needed]: No.
Attachment #8818953 - Flags: approval-mozilla-beta?
Attachment #8818953 - Flags: approval-mozilla-aurora?
Comment on attachment 8818953 [details]
Bug 1322730 - display undo migration message on about:newtab,

Part of funnelcake project for 51. 
I hope this can make it to beta 12 but if not, it'll be in Monday's beta 13 build.
Attachment #8818953 - Flags: approval-mozilla-beta?
Attachment #8818953 - Flags: approval-mozilla-beta+
Attachment #8818953 - Flags: approval-mozilla-aurora?
Attachment #8818953 - Flags: approval-mozilla-aurora+
Flagging this for verification based on the instructions from Comment 9. Grover -- hopefully you still have some bandwidth left to take this.
Flags: qe-verify+
Flags: needinfo?(gwimberly)

Updated

3 years ago
Flags: needinfo?(gwimberly)

Updated

2 years ago
Status: RESOLVED → VERIFIED
 Hi Gijs,
Could you possibly provide a custom build for us to test this issue on? Thank you.
Flags: needinfo?(gijskruitbosch+bugs)
Assignee

Comment 15

2 years ago
(In reply to Alexandru Simonca, QA (:asimonca) from comment #14)
>  Hi Gijs,
> Could you possibly provide a custom build for us to test this issue on?
> Thank you.

You shouldn't need a custom build anymore - you can try current nightly (which after bug 1343076 has automigration enabled), and start it with the -migration commandline flag. You'll need to make sure another browser (IE/Edge/Chrome/Safari) is set as the default browser on the machine and has importable data (history, bookmarks, passwords) that it then automatically imports (if you see the import wizard, that bit is not working). When using Chrome as the browser to automatically import from, it also only works on machines with only 1 Chrome profile.
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(alexandru.simonca)
I understand but I was going to verify the 52 & 53 builds since their flags are set to "fixed". Will it work on those?
Flags: needinfo?(alexandru.simonca) → needinfo?(gijskruitbosch+bugs)
Assignee

Comment 17

2 years ago
(In reply to Alexandru Simonca, QA (:asimonca) from comment #16)
> I understand but I was going to verify the 52 & 53 builds since their flags
> are set to "fixed". Will it work on those?

On 53 yes, because automigration is currently enabled on 53 as well. On 52 release, no, because it's been disabled there, but you could use the previously-shipped 52 beta 8 to check it there. This bug landed on 52 when it was still on aurora, and on 52 we enabled automigration for "a while". Does that help?
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(alexandru.simonca)
Assignee

Comment 18

2 years ago
(In reply to :Gijs from comment #17)
> on 52 we enabled automigration for "a while".

This should have read 'on 52 beta'. :-)
I've tested this issue using Comment #15 as a guideline and managed to automigrate data from Chrome to Firefox on Beta 52.0b8 and Firefox 53.0b1 on Windows 8.1 x86 and on Beta 53.0b1 on Mac OS 10.11.6. I consider it Verified Fixed since it worked on 52 and 53. Please ni? me if there are any concerns.
Flags: qe-verify+
Flags: needinfo?(alexandru.simonca)
You need to log in before you can comment on or make changes to this bug.