Cursor is offset from insertion point

VERIFIED FIXED in mozilla1.1beta

Status

()

Core
Selection
VERIFIED FIXED
17 years ago
4 years ago

People

(Reporter: David Bradley, Assigned: mjudge)

Tracking

Trunk
mozilla1.1beta
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE+)

Attachments

(4 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4.1)
Gecko/20020314 Netscape6/6.2.2
BuildID:    20020319 Trunk

The cursor is not positioned at insertion point. If I move to text near the far
right, the cursor is about one character passed the point of insertion.

Reproducible: Always
Steps to Reproduce:
1. Open Composer
2. Open a document with long lines, 120 characters or more. or create a line
3. Click on a position near the far right noting where you clicked
4. Type some text, notice where the text shows up

Actual Results:  Characters typed appear slightly before where the cursor is
positioned.

Expected Results:  Characters should appear where the cursor was positioned

I tried this on Linux, and it appears to be a Windows only problem.

Comment 1

17 years ago
--> Joe
Assignee: syd → jfrancis

Comment 2

17 years ago
David, you are using 0.9.4 but your build ID says 3/19 trunk.

can you try the latest build. should be working...
Assignee: jfrancis → kin

Comment 3

17 years ago
This was fixed in mozilla0.9.9.

*** This bug has been marked as a duplicate of 83650 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

17 years ago
I see the problem on a CVS build I pulled on 3/19/02. I filed the but with
Netscape 6.22. This may be a duplicate, but it's back if it is.

I'll attach a screen shot
(Reporter)

Comment 5

17 years ago
Created attachment 75209 [details]
Example of caret positioned incorrectly

Comment 6

17 years ago
dbradley--I believe you are really seeing bug 98564
Could you verify that this bug is really a duplicate of that bug?

Comment 7

17 years ago
brade's right, reopening so I can re-dup.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 8

17 years ago

*** This bug has been marked as a duplicate of 98564 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 9

17 years ago
Created attachment 75212 [details]
Another example

Unfortunately it's not. This occurs in the middle of the line as well, not just
the end, and it's a full character off. The new gif I attached is a better
example. I typed the letter 'f' after clicking just past the second 's' in the
word 'issues'.

Comment 10

17 years ago
reopen bug
Status: RESOLVED → REOPENED
Component: Editor: Composer → Editor: Core
Resolution: DUPLICATE → ---
Summary: Cursor is offset from insertion point → caret is offset from insertion point

Updated

17 years ago
Component: Editor: Core → Editor: Composer
Summary: caret is offset from insertion point → Cursor is offset from insertion point
(Reporter)

Comment 11

17 years ago
Created attachment 75215 [details]
This is HTML that demonstrates problem in Composer

I put the insert text here sentence. Make your window wide enough to have this
near the end of the line.

Comment 12

17 years ago
Created attachment 75232 [details]
Test Case for debugging.

This bug seems related to multiple spaces in a textnode, coupled with wrapping,
as this test case shows.

Updated

17 years ago
Status: REOPENED → ASSIGNED
Keywords: nsbeta1
Priority: -- → P3
Whiteboard: EDITORBASE
Target Milestone: --- → mozilla1.0

Comment 13

17 years ago
--> mjudge (selection/caret)

Giving to mjudge since he owns selection/caret, and I think he wrote the code
that calculates the x coordinate which the caret uses.
Assignee: kin → mjudge
Status: ASSIGNED → NEW
Component: Editor: Composer → Selection
Priority: P3 → --
Target Milestone: mozilla1.0 → ---

Comment 14

17 years ago
Marking EDITORBASE-
Whiteboard: EDITORBASE → EDITORBASE-

Updated

17 years ago
Target Milestone: --- → mozilla1.1beta

Comment 15

16 years ago
Cursor is also offset in the dialog boxes that you use to set up Mail.  The
cursor is always one pixel width left of where it should be.  The result is that
you can't see the right edge of the letter that you last typed.  It consistently
does this.

Comment 16

16 years ago
EDITORBASE+, need to figure out if this still happens on all platforms. qawanted
Keywords: qawanted
QA Contact: sujay → beppe
Whiteboard: EDITORBASE- → EDITORBASE+
(Reporter)

Comment 17

16 years ago
On my system now, with a build from yesterday (2/20/03) it looks better, but it
still seems to be slightly to the left. I've changed systems since I first saw
this behavior, so I don't know if that's the cause, or if something in Mozilla
changed that made this better.

Comment 18

16 years ago
this works fine on win and mac OSx, marking verified
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED

Comment 19

16 years ago
verified
Status: RESOLVED → VERIFIED
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.