Last Comment Bug 1322975 - devedition.inc.css can stop resetting padding-top and padding-bottom on #nav-bar-customization-target
: devedition.inc.css can stop resetting padding-top and padding-bottom on #nav-...
Status: RESOLVED FIXED
[good first bug][lang=css]
: good-first-bug
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: Unspecified Mac OS X
P3 normal (vote)
: Firefox 53
Assigned To: Aniruddha Patil
:
: Dão Gottwald [:dao]
Mentors: Dão Gottwald [:dao]
Depends on: 1322430
Blocks:
  Show dependency treegraph
 
Reported: 2016-12-12 02:45 PST by Dão Gottwald [:dao]
Modified: 2016-12-19 16:47 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
bug1322975.patch (717 bytes, patch)
2016-12-18 22:57 PST, Aniruddha Patil
dao+bmo: review+
Details | Diff | Splinter Review

Description User image Dão Gottwald [:dao] 2016-12-12 02:45:07 PST
Bug 1322430 made the Mac theme not set padding-top and padding-bottom on #nav-bar-customization-target anymore. The Windows and Linux themes didn't set padding-top or padding-bottom in the first place. This means that #nav-bar-customization-target is now redundant here:

https://dxr.mozilla.org/mozilla-central/rev/8103c612b79c2587ea4ca1b0a9f9f82db4b185b8/browser/themes/shared/devedition.inc.css#234
Comment 1 User image Aniruddha Patil 2016-12-17 09:29:04 PST
Hello! I would like to take up this bug. Since this is my first bug, a little information on how to get started would help me greatly.
Comment 2 User image Dão Gottwald [:dao] 2016-12-17 09:34:22 PST
(In reply to Aniruddha Patil from comment #1)
> Hello! I would like to take up this bug. Since this is my first bug, a
> little information on how to get started would help me greatly.

Have you already built Firefox?
https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Build_Instructions/Simple_Firefox_build
Comment 3 User image Aniruddha Patil 2016-12-17 22:38:42 PST
(In reply to Dão Gottwald [:dao] from comment #2)
> (In reply to Aniruddha Patil from comment #1)
> > Hello! I would like to take up this bug. Since this is my first bug, a
> > little information on how to get started would help me greatly.
> 
> Have you already built Firefox?
> https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/
> Build_Instructions/Simple_Firefox_build

Yes. I've built it.
Comment 4 User image Dão Gottwald [:dao] 2016-12-18 07:06:55 PST
The next step would be to open browser/themes/shared/devedition.inc.css in the editor of your choice and make the change that I described in comment 0.
Comment 5 User image Aniruddha Patil 2016-12-18 08:21:27 PST
(In reply to Dão Gottwald [:dao] from comment #4)
> The next step would be to open browser/themes/shared/devedition.inc.css in
> the editor of your choice and make the change that I described in comment 0.

I have removed the redundancy as you had described.
Comment 6 User image Dão Gottwald [:dao] 2016-12-18 10:02:44 PST
Have you created a patch?
Comment 7 User image Aniruddha Patil 2016-12-18 10:58:00 PST
No. How do I make one?
Comment 8 User image Dão Gottwald [:dao] 2016-12-18 11:33:08 PST
The simplest way is hg diff:

https://developer.mozilla.org/en-US/docs/Mercurial/Using_Mercurial#How_can_I_diff_and_patch_files.3F
Comment 9 User image Aniruddha Patil 2016-12-18 12:31:34 PST
(In reply to Dão Gottwald [:dao] from comment #8)
> The simplest way is hg diff:
> 
> https://developer.mozilla.org/en-US/docs/Mercurial/
> Using_Mercurial#How_can_I_diff_and_patch_files.3F

I have made a local commit. Using hg push review tells me to provide an ircnick. But I do not have one. How do I proceed further?
Comment 10 User image Dão Gottwald [:dao] 2016-12-18 13:01:35 PST
Not sure how that works. After committing you can also just export the patch using hg export, then upload the patch file manually as an attachment on this bug page.
Comment 11 User image Aniruddha Patil 2016-12-18 22:57:59 PST
Created attachment 8819756 [details] [diff] [review]
bug1322975.patch
Comment 12 User image Aniruddha Patil 2016-12-18 23:48:36 PST
(In reply to Dão Gottwald [:dao] from comment #10)
> Not sure how that works. After committing you can also just export the patch
> using hg export, then upload the patch file manually as an attachment on
> this bug page.

I have attached the patch as you said.
Comment 13 User image Dão Gottwald [:dao] 2016-12-19 03:36:38 PST
Comment on attachment 8819756 [details] [diff] [review]
bug1322975.patch

Perfect, thanks!
Comment 14 User image Pulsebot 2016-12-19 03:39:41 PST
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5926190be105
Removed the redundant #nav-bar-customization-target in devedition.inc.css. r=dao
Comment 15 User image Aniruddha Patil 2016-12-19 10:31:10 PST
(In reply to Dão Gottwald [:dao] from comment #13)
> Comment on attachment 8819756 [details] [diff] [review]
> bug1322975.patch
> 
> Perfect, thanks!

Thanks for the guidance! :)
Comment 16 User image Wes Kocher (:KWierso) 2016-12-19 16:47:42 PST
https://hg.mozilla.org/mozilla-central/rev/5926190be105

Note You need to log in before you can comment on or make changes to this bug.