There is a javascript problem on Ofoto View albums page

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
4 years ago

People

(Reporter: pj_gillis, Assigned: doronr)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020311
BuildID:    -0.9.9.9

There is a menu option "Edit Album" that uses javascript.  This option doesn't
work on Mozilla for Linux or Windows.  It works fine for Netscape 4.78.

Reproducible: Always
Steps to Reproduce:
1.Browse to the ofoto site and click on an album to view.
2.On the right side click the edit album button.
3.

Actual Results:  Nothing happens.

Expected Results:  There should be a list of options that open up below the Edit
Album button that you can choose from.

This works fine under Netscape 4.78...I don't know if its related, but in the
javascript console there is an entry saying:

Error:  menuBar is not defined with a tag for the source file.

Comment 1

17 years ago
Reassigning to Browser-General until we can get further information.
This is unlikely to be a bug in the JS Engine.

Pete: could you paste that JS Console error here? We'd like to see
the URL the error points to.

Also: would it be possible to set up a test account at the site
for us, e.g. with UserID=mozilla, Password=bugzilla? I would do 
this myself, but I'm not familiar with how to create an album
to edit, etc.

I'm afraid that if we can't step through the code, we won't be able
to figure this one out - 
Assignee: rogerl → asa
Component: JavaScript Engine → Browser-General
QA Contact: pschwartau → doronr

Comment 2

17 years ago
-> evang

snipplet of code:
if (document.layers) {
visible = 'show';
hidden = 'hide';
} else if (document.all) {
visible = 'visible';
hidden = 'hidden';
}

no document.layers and no document.all then do nothing.
nice of them.
Assignee: asa → doronr
Status: UNCONFIRMED → NEW
Component: Browser-General → US General
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: doronr → zach
Version: other → unspecified
(Reporter)

Comment 3

17 years ago
This is the entry in the javascript console:

Error: menuBar is not defined
Source File:
http://www.ofoto.com/BrowsePhotos.jsp?UV=282521873803_88463777303&US=0&collid=42436781303
Line: 519

I don't know if you'll be able to get to it without the password...to set up an
account I'd need to use an email address, is there one I can use that will point
to this bug?

Thanks...

Comment 4

17 years ago
no need. i already found the problem. the site does not supply code that works
with mozilla. 

this is now an evangelism bug(contacting the webmaster, etc)

Comment 5

17 years ago
I just tried this again and it appears to work now. I have tried it on Mozilla 
1.0 and 1.1a and "Edit Album" works with both. 
(Assignee)

Comment 6

17 years ago
created test account, worksforme. Please reoopen if this still happens.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.