Closed Bug 1323160 Opened 6 years ago Closed 5 years ago

[PointerEvents][web-platform-tests] Fail to get expect result status when running "pointerevent_suppress_compat_events_on_click-manual"

Categories

(Core :: DOM: Events, defect, P3)

53 Branch
x86_64
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1323158
Tracking Status
firefox53 --- affected

People

(Reporter: cynthiatang, Assigned: stone)

References

Details

Test Description: 
When a pointerdown is canceled, a click/tap shouldn't fire any compatibility mouse events.

Steps to reproduce:
 1. Launch Firefox with Pointer Events
 2. Go to http://w3c-test.org/pointerevents/pointerevent_suppress_compat_events_on_click-manual.html
 3. Start the manual 
    (1) Click or tap on Target0.
    (2) Click or tap on Target1.
    (3) Click Done.

Expected result:
 - Return result status is "PASS".

Actual result:
 - 3 PASS
 - 1 FAIL:
   - Test Name: Event log
   - Error Message: 
     assert_equals: expected "mousedown@target1, mouseup@target1" but got "mousedown@target0, mouseup@target0, mousedown@target1, mouseup@target1" end_of_interaction/<@http://w3c-test.org/pointerevents/pointerevent_suppress_compat_events_on_click-manual.html:26:15
     Test.prototype.step@http://w3c-test.org/resources/testharness.js:1406:20
     test@http://w3c-test.org/resources/testharness.js:501:9
     end_of_interaction@http://w3c-test.org/pointerevents/pointerevent_suppress_compat_events_on_click-manual.html:25:11
     EventListener.handleEvent*on_event@http://w3c-test.org/resources/testharness.js:665:9
     run@http://w3c-test.org/pointerevents/pointerevent_suppress_compat_events_on_click-manual.html:34:11
     onload@http://w3c-test.org/pointerevents/pointerevent_suppress_compat_events_on_click-manual.html:1:1

Environment:
 - Devices: Surface 3
 - OS: Windows 10 Pro. (64-bit)
 - Firefox: 53.0a1 (2016-11-30) (64-bit)
Priority: -- → P3
Assignee: nobody → sshih
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1323158
You need to log in before you can comment on or make changes to this bug.