Add-On caused: Selected tag from context menu will not be assigned to selected Email

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: domfillon, Unassigned)

Tracking

SeaMonkey 2.49 Branch
x86_64
Windows 10

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49a2
Build ID: 20161213024455

Steps to reproduce:

Using SeaMonkey nightly 20161213 (windows 32 bits), I am unable to ag any message. the tag definition is visible in the preferences menu though.


Actual results:

unable to tag Email


Expected results:

Email should be tagged (i.e. summary / subject line color changed as per the tagging configuration in preferences).
(Reporter)

Comment 1

2 years ago
Email tagging works on SeaMonkey 2.49a2 (20161213)
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Comment 2

2 years ago
NOT reproducible with Server-Installation of  official en-US SeaMonkey 2.50a1 (NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0 Build 20161213002544  (Default Classic Theme) on German WIN7 64bit.

@reporter:
I have some difficulties to understand your sophisticated Build ID differences ;-)

Comment 3

2 years ago
Also NOT reproducible with Server-Installation of official en-US SeaMonkey 2.49a2  (NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 Build 20161213024455  (Default Classic Theme) on German WIN7 64bit:

I tried in Inbox of a POP3 account and Postings on news.mozilla.org - mozilla.dev.apps.seamonkey; Color changes to red as expected after having assigned gag "important"

Comment 4

2 years ago
@reporter, Please:
a) Contribute a problem related step by step instruction containing every 
   key press and every mouse click how to reproduce your problem due to 
   <https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines>
   (similar to report in Bug 1139273)
b) Attach screenshots with comments if you believe that that might explain the 
   problem better than a text comment. Best way is to insert your screenshots
   into a OOo or LibreOffice DRAW document and to add comments 
   that explain what you want to show (attach .png or PDF from source document)
c) add information 
c1) concerning your Operating System (Version, Distribution, Language)
c2) concerning your SM localization (UI language, Locale setting)
c3) SM settings that might be related to your problems 
    May be you should attach a copy of menu 
   'Help → Trouble shooting information”' as a text document
c4) how you launch SM (Double click on document? console? …)
c5) Whether problem persists in safe mode without add-ons
c6) Whether problem persists with blank new profile
c7) everything else crossing your mind after you read linked texts
d)  An URL for a web page where you observe the problem.
e) Complete list of settings you used due to recommendations of Thunderbird
  (what work) and all differences in settings due to recommendation of SeaMonkey
f) Your Email-Service-Provider (if not visible in (e))
g) POP3 or IMAP account?
Flags: needinfo?(dominique)

Updated

2 years ago
Summary: SeaMonkey nightly do not allow Email tags (although configured) → Selected tag from context menu will not be assigned to selected Email
(Reporter)

Comment 5

2 years ago
User agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0 SeaMonkey/2.50a1
Build identifier: 20161213002544

STR: 
- IMAP accounts (main one being on office 365.com)
- select one Email
- either: type 1 to tag it as important or right click
- Result: no tag applied
- See screenshot attached for right click: no tag listed
- Will test in safe mode
(Reporter)

Comment 6

2 years ago
Created attachment 8818316 [details]
tag  right click screenshot

Comment 7

2 years ago
Ah, it seems I misunderstood your problem.

Can you please try with a newly created user profile if Safe mode does not heal your problem?
Summary: Selected tag from context menu will not be assigned to selected Email → Configured Tags from Preferences are not listed neither in TAG menu not in TAG context menu

Comment 8

2 years ago
Also item "Remove all Tags" is missing in menu shown in your screenshot
Summary: Configured Tags from Preferences are not listed neither in TAG menu not in TAG context menu → Configured Tags from Preferences are not listed, neither in TAG menu not in TAG context menu

Comment 9

2 years ago
Also not reproducible with above mentioned 2.49 and MODERN Theme.

a) User Profile related?
b) WIN10 related?
(Reporter)

Comment 10

2 years ago
OK, found the guilty add-on: 
Exchange EWS provider is causing this problem.

https://github.com/Ericsson/exchangecalendar

Problem is that they are not responsive to nightly bugs in Thunderbird or Seamonkey !

Sorry for the noise, Thanks Rainer for the guidance.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Summary: Configured Tags from Preferences are not listed, neither in TAG menu not in TAG context menu → Selected tag from context menu will not be assigned to selected Email

Comment 11

2 years ago
Thx. But if they know that there is a problem they might watch the situation, might find a problem in Mailnews core or in their add-on, so it can help if you stay in contact with developers of that add-on.
Flags: needinfo?(dominique)
Summary: Selected tag from context menu will not be assigned to selected Email → Add-On caused: Selected tag from context menu will not be assigned to selected Email
You need to log in before you can comment on or make changes to this bug.