Closed Bug 1323349 Opened 5 years ago Closed 5 years ago

Firefox crash in Linux with X11 BadAccess error and SIGTRAP in libglib when viewing book previews in Amazon

Categories

(Firefox :: Untriaged, defect)

50 Branch
x86_64
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1271100

People

(Reporter: riclc, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161130094630

Steps to reproduce:

1. Open Firefox
2. Visit Amazon and start viewing previews of books in new tabs
3. Eventually Firefox crashes


Actual results:

Firefox crashes.

My version: 50.0.2.
Using Linux. No plugins (Flash, Java etc.) are enabled.

Using GDB it shows this:
(firefox:7625): Gdk-ERROR **: The program 'firefox' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAccess (attempt to access private resource denied)'.
  (Details: serial 3019 error_code 10 request_code 130 (MIT-SHM) minor_code 1)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Thread 1 "firefox" received signal SIGTRAP, Trace/breakpoint trap.
0x00007ffff1eb7241 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0

#0  0x00007ffff1eb7241 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007ffff1eb9961 in g_log_writer_default ()
   from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ffff1eb7ddc in g_log_structured_array ()
   from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ffff1eb80d9 in g_log_structured ()
   from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007ffff484f87e in ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
#5  0x00007ffff485ca53 in ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
#6  0x00007ffff40e2c2d in _XError () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#7  0x00007ffff40dfab7 in ?? () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#8  0x00007ffff40dfb75 in ?? () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#9  0x00007ffff40e0535 in _XEventsQueued ()
   from /usr/lib/x86_64-linux-gnu/libX11.so.6
#10 0x00007ffff40d1f17 in XPending ()
   from /usr/lib/x86_64-linux-gnu/libX11.so.6
#11 0x00007ffff4856fce in ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
#12 0x00007ffff1eb0ed9 in g_main_context_prepare ()
   from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007ffff1eb18fb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#14 0x00007ffff1eb1aec in g_main_context_iteration ()
   from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#15 0x00007fffe90e4a17 in ?? () from /usr/lib/firefox/libxul.so
#16 0x00007fffe90ca603 in ?? () from /usr/lib/firefox/libxul.so
#17 0x00007fffe90ca6ba in ?? () from /usr/lib/firefox/libxul.so
#18 0x00007fffe7c98c85 in ?? () from /usr/lib/firefox/libxul.so
#19 0x00007fffe7cb3a0b in ?? () from /usr/lib/firefox/libxul.so
#20 0x00007fffe7f6ff69 in ?? () from /usr/lib/firefox/libxul.so
#21 0x00007fffe7f5afa6 in ?? () from /usr/lib/firefox/libxul.so
#22 0x00007fffe90c850c in ?? () from /usr/lib/firefox/libxul.so
#23 0x00007fffe9739baa in ?? () from /usr/lib/firefox/libxul.so
#24 0x00007fffe977f530 in ?? () from /usr/lib/firefox/libxul.so
#25 0x00007fffe977f805 in ?? () from /usr/lib/firefox/libxul.so
#26 0x00007fffe977fa67 in XRE_main () from /usr/lib/firefox/libxul.so
#27 0x000055555555922e in ?? ()
#28 0x00005555555587e7 in ?? ()
#29 0x00007ffff6d673f1 in __libc_start_main (main=0x555555558780, argc=1, 
    argv=0x7fffffffdd68, init=<optimized out>, fini=<optimized out>, 
    rtld_fini=<optimized out>, stack_end=0x7fffffffdd58)
    at ../csu/libc-start.c:291
#30 0x00005555555589ea in _start ()



Expected results:

Firefox should not crash.
Severity: normal → critical
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
It's fixed in the new 50.1.0, just update.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1271100
You need to log in before you can comment on or make changes to this bug.