Closed Bug 1323843 Opened 3 years ago Closed 3 years ago

add test for beConservative option added in bug 1321783

Categories

(Core :: Networking, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox51 --- fixed
firefox52 --- fixed
firefox53 --- fixed

People

(Reporter: keeler, Assigned: keeler)

References

Details

(Whiteboard: [necko-active])

Attachments

(1 file)

Bug 1321783 added nsIHttpChannelInternal.beConservative as a way to make a channel use conservative TLS settings when connecting. It took a while, but I managed to get together a test for this feature, so I'm adding it now.
Comment on attachment 8819062 [details]
bug 1323843 - add a test for conservative TLS option added in bug 1321783

https://reviewboard.mozilla.org/r/98926/#review99228

really appreciate this. thanks.
Attachment #8819062 - Flags: review?(mcmanus) → review+
Whiteboard: [necko-active]
Pushed by dkeeler@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5182a866ae5a
add a test for conservative TLS option added in bug 1321783 r=mcmanus
https://hg.mozilla.org/mozilla-central/rev/5182a866ae5a
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Comment on attachment 8819062 [details]
bug 1323843 - add a test for conservative TLS option added in bug 1321783

Approval Request Comment
[Feature/Bug causing the regression]: n/a (this is just a test for the feature added in bug 1321783)
[User impact if declined]: no test coverage for feature
[Is this code covered by automated tests?]: it is the test
[Has the fix been verified in Nightly?]: not by QA, no (although, again, this is the test)
[Needs manual test from QE? If yes, steps to reproduce]: probably not
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: it's just a test
[String changes made/needed]: none
Attachment #8819062 - Flags: approval-mozilla-aurora?
This can go in with a=test-only.
Whiteboard: [necko-active] → [necko-active][checkin-needed-aurora]
Attachment #8819062 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/releases/mozilla-aurora/rev/75a0d7ccab1c
Whiteboard: [necko-active][checkin-needed-aurora] → [necko-active]
Oh, right - of course. Thanks!
In the meantime, bug 1321783 got uplifted to beta, so we need this there as well.
Whiteboard: [necko-active] → [necko-active][checkin-needed-beta]
https://hg.mozilla.org/releases/mozilla-beta/rev/31a671ef6c6f
Flags: in-testsuite+
Whiteboard: [necko-active][checkin-needed-beta] → [necko-active]
Depends on: 1324952
Thanks for tracking that down. It looks like I'm a bit late to uplift that and re-enable this test, since the tree is now closed for uplift week (I would have done it yesterday with a=test-only, but claiming that the relevant patch from bug 1286694 is test-only is a slight stretch).
Flags: needinfo?(dkeeler)
Code freeze for 51 isn't until next week.
Flags: needinfo?(dkeeler)
Oh - I must be misunderstanding the tree status annotation. In any case, I went ahead and asked for uplift for the part 2 patch in bug 1286694 (since part 1 landed in 50). After that lands, we should be able to just back out 5df4fe2cddb45311fa3e8ac0dc58f04364ffffb9.
Flags: needinfo?(dkeeler)
You need to log in before you can comment on or make changes to this bug.