Tab always loads home page URL before restored session page

RESOLVED DUPLICATE of bug 1054740

Status

()

Firefox
Session Restore
RESOLVED DUPLICATE of bug 1054740
a year ago
a year ago

People

(Reporter: Mark Straver, Unassigned)

Tracking

({dupeme})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
Firefox 50 32-bit on Win 7 x64 desktop.

It looks like pending tabs always initially load whatever is set as the home page first before filling it with the proper content. This causes unnecessary network traffic (and unnecessary processing) for something that will have no use for the user as it is immediately replaced with other content. The network traffic is problematic as it potentially discloses browser startup to the operators of the homepage URL (privacy issue).

You can easily reproduce this by having a quick-loading (internal) page as home page and using session restore:

1. Set about:about as your home page
2. Set "Restore my windows and tabs from last time" and "don't load tabs until selected"
3. Open a number of pages in tabs; it's clear on my system if I open a handful of pages.
4. Select a tab that is not the first tab
5. Shut down Firefox and re-open it
-> The tab that is active on startup briefly flashes about:about before restoring the tab contents
6. Switch to the first tab on the tab bar
-> Once again, about:about flashes briefly into view before the tab contents is restored

It seems to me that what should happen in these tabs is not loading the home page URL, but rather about:blank, before restoring the session tab contents.

This is a long-standing bug, all older versions of Firefox I tried display this behavior.
Blocks: 1330638
Keywords: dupeme
See Also: → bug 1320902
No longer blocks: 1330638
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
See Also: bug 1320902
Duplicate of bug: 1054740
You need to log in before you can comment on or make changes to this bug.