Closed Bug 1324289 Opened 6 years ago Closed 3 years ago

Send clipboard/pasteboard content to other devices

Categories

(Firefox :: Sync, enhancement, P3)

enhancement

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: krzysztof.glebowicz, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [sync-engine-addition])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.0; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20161118030222




Expected results:

I'd like to have synced the content I copied (Ctrl+C), (for instance text, url address) and to have the availability to paste it (Ctrl+V) on a different device connected to Firefox Sync.
Component: General → Firefox Sync: Backend
This has interesting UX challenges, particularly on Mac. This might work like "Send Tab", where you specifically send the contents of the clipboard instead of automatically syncing. Hello also had mechanisms to detect copy-pastes and give contextual sharing hints. We could do something like that here.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
I could see this being useful if tightly scoped and perhaps non-automatic. It'd be maddening to have Firefox on one device blow away my clipboard just because I hit Cmd-C on another device.

See also macOS Sierra's "Universal Clipboard", which does something similar.
Summary: Ability to sync copied content and paste it on a different device → Sync or send clipboard/pasteboard content
Whiteboard: [sync-engine-addition]
I don't believe there is an existing way to deliver this content, and overwriting the clipboard would not fly. But perhaps when is text selected on a page, "Send selection to device" could be present. It could send the page to the user and select the same content, so it could easily be copied.
Would it be easier to make "Send selection to device" option on a origin device and "Paste selection from different device" (if present) on a target device?
(In reply to Krzysztof from comment #4)
> Would it be easier to make "Send selection to device" option on a origin
> device and "Paste selection from different device" (if present) on a target
> device?

Can you give some real world examples so I can better understand how one would use such a feature.
Example from mobile to desktop, from desktop to mobile, from desktop to desktop
Flags: needinfo?(krzysztof.glebowicz)
(In reply to Ryan Feeley [:rfeeley] from comment #5)
> Can you give some real world examples so I can better understand how one
> would use such a feature.

From desktop to desktop: you can start make a bugzilla comment at home, then copy your textarea, and finish writing it at work. 

From desktop to mobile: things, you could use on different device/environment: phone number, gps coordinates, shopping list.
Flags: needinfo?(krzysztof.glebowicz)
Attached image notepad.jpg
Would something like this work? Just a mockup for a possible Test Pilot experiment.
Flags: needinfo?(krzysztof.glebowicz)
Yeah OK, that would fullfill my needs. Thanks for doing it. 

Great idea with this Test Pilot experiment.
Flags: needinfo?(krzysztof.glebowicz)
(In reply to Ryan Feeley [:rfeeley] from comment #7)
> Would something like this work?

That's likely to be tricky to implement assuming we allow concurrent edits on different devices that we then need to merge. Kinda like implementing bits of git ;)
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
Priority: -- → P3
Summary: Sync or send clipboard/pasteboard content → Send clipboard/pasteboard content to other devices

It’s perhaps worth noting that if you have Notes extension installed and open, you can select text and in the contextual menu select Add to Notes which creates a new note with this content. If you are syncing this is a pretty good solution for this bug (but text only).

I'm happy with the current solution, the bug can be closed.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 1742288
You need to log in before you can comment on or make changes to this bug.