Intermittent browser/base/content/test/popupNotifications/browser_popupNotification_checkbox.js | Test timed out -

RESOLVED FIXED in Firefox 52

Status

()

RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: intermittent-bug-filer, Assigned: johannh)

Tracking

({intermittent-failure})

unspecified
Firefox 54
intermittent-failure
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox52 fixed, firefox-esr52 fixed, firefox53 fixed, firefox54 fixed)

Details

(Whiteboard: [stockwell fixed])

Attachments

(1 attachment)

huge spike for this bug in the last 2 days.  

I have some retriggers on osx debug:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&filter-searchStr=osx%20bc%20debug%20e10s&tochange=28a77830566502e6b3f2f71581175f4f2bec3b3e&fromchange=96b2668cb9ca691a4514e5a7a16bab5ec0c210cc&selectedJob=74797088

we also see this on win7-vm opt although a lower frequency.

this test is timing out, and over the last week on all platforms we complete in <5 seconds, for osx debug it is typically 2-3 seconds.  

here is a screenshot from osx debug failure:
http://mozilla-releng-blobs.s3.amazonaws.com/blobs/mozilla-inbound/sha512/726d9b964b93f5abffd4d76c2944716f5625897ea0f9cb92c7ad01f7681ac327a45a131690f658be2b46841506acc28817143917d5266801ba6f1983a9f28843

and the related log:
https://archive.mozilla.org/pub/firefox/tinderbox-builds/mozilla-inbound-macosx64-debug/1486394510/mozilla-inbound_yosemite_r7-debug_test-mochitest-e10s-browser-chrome-7-bm106-tests1-macosx-build119.txt.gz

I suspect this is failing on line 157:
https://dxr.mozilla.org/mozilla-central/source/browser/base/content/test/popupNotifications/browser_popupNotification_checkbox.js?q=path%3Abrowser_popupNotification_checkbox.js&redirect_type=single#157

although it is hard to tell, we get this block from checkMainAction() and stop:
08:57:29     INFO - TEST-PASS | browser/base/content/test/popupNotifications/browser_popupNotification_checkbox.js | Checkbox should have the correct label - 
08:57:29     INFO - TEST-PASS | browser/base/content/test/popupNotifications/browser_popupNotification_checkbox.js | Checkbox should be shown - 
08:57:29     INFO - TEST-PASS | browser/base/content/test/popupNotifications/browser_popupNotification_checkbox.js | Checkbox should be checked by default - 
08:57:29     INFO - TEST-PASS | browser/base/content/test/popupNotifications/browser_popupNotification_checkbox.js | Warning label should be shown - 
08:57:29     INFO - TEST-PASS | browser/base/content/test/popupNotifications/browser_popupNotification_checkbox.js | MainAction should be disabled - 

I will chime in when the results come in from retriggers.

:johannh, I see you are the original patch author, can you look at this sometime this week or next week?
Flags: needinfo?(jhofmann)
ok, this worked out pretty easy, there are 3 patches which landed and caused this test to start failing:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=579e613faefe

:johannh, one you had reviewed (bug 1331524), and another looks like a possibility (bug 1220936).
(Assignee)

Comment 3

2 years ago
Interesting, thanks for digging into this. I can not imagine how bug 1331524 could have caused this but I'll investigate.
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Flags: needinfo?(jhofmann)
Comment hidden (mozreview-request)
(Assignee)

Comment 5

2 years ago
This solution is completely unrelated to the patches you mentioned and tbh I have no idea how any of those could have caused this, but I still think it's the right thing to do and I can't reproduce the intermittent locally anymore (took less than 5 runs on --run-until-fail before).

I suspect the problem was that the onShown callback of the reshow test was racing with the next test (which is also showing a popupnotification) because onShown did not support generator functions yet. I changed that and added a yield.

I'll make a try push with lots of retriggers.
(Assignee)

Comment 6

2 years ago
(In reply to Johann Hofmann [:johannh] from comment #5) 
> I suspect the problem was that the onShown callback of the reshow test was
> racing with the next test (which is also showing a popupnotification)
> because onShown did not support generator functions yet. I changed that and
> added a yield.

s/onShown/onHidden

Comment 8

2 years ago
mozreview-review
Comment on attachment 8834554 [details]
Bug 1324497 - Wait for popupshow to fix intermittent in browser_popupNotification_checkbox.js.

https://reviewboard.mozilla.org/r/110438/#review111782

I could swear I had this head.js change in one of my patches at one point, but I must have dropped it for some reason. Thanks!
Attachment #8834554 - Flags: review?(past) → review+

Comment 9

2 years ago
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fe7aa94a46ec
Wait for popupshow to fix intermittent in browser_popupNotification_checkbox.js. r=past

Comment 10

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/fe7aa94a46ec
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox54: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
status-firefox52: --- → affected
status-firefox53: --- → affected

Comment 11

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/ca9697c035cd
status-firefox53: affected → fixed
Flags: in-testsuite+

Comment 12

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/59b7226fcd5e
status-firefox52: affected → fixed
108 failures in 836 pushes (0.129 failures/push) were associated with this bug in the last 7 days. 

This is the #15 most frequent failure this week. 

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. **

Repository breakdown:
* mozilla-inbound: 49
* autoland: 40
* try: 9
* mozilla-central: 7
* graphics: 2
* mozilla-beta: 1

Platform breakdown:
* osx-10-10: 66
* windows7-32-vm: 30
* windows8-64: 11
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1324497&startday=2017-02-06&endday=2017-02-12&tree=all
Whiteboard: [stockwell fixed]
1 failures in 822 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* try: 1

Platform breakdown:
* windows10-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1324497&startday=2017-07-17&endday=2017-07-23&tree=all
You need to log in before you can comment on or make changes to this bug.