Closed Bug 1324868 Opened 6 years ago Closed 6 years ago

Fix Narrate telemetry to record initializations

Categories

(Toolkit :: Reader Mode, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox51 --- unaffected
firefox52 --- fixed
firefox53 --- fixed

People

(Reporter: eeejay, Assigned: eeejay)

References

Details

Attachments

(1 file)

The `initial` flag in NarrateControls._setupVoices was mistakenly inverted.
This renders the data we got so far as junk. If we can push a fix forward to beta before merge to release, we will get accurate data in the release channel.

Benjamin, would that be the correct course? Sorry for this screwup. We can also discontinue that histogram name.
Flags: needinfo?(benjamin)
Comment on attachment 8820376 [details]
Bug 1324868 - invert `initial` flag in NarrateContols._setupVoices to correct value.

https://reviewboard.mozilla.org/r/99874/#review100316

D'oh. Sorry for missing this in the original review.
Attachment #8820376 - Flags: review?(gijskruitbosch+bugs) → review+
You are welcome to rename the histogram (e.g. "_2") if that would help your analysis. Do whatever is better for you, no additional data review needed for that.
Flags: needinfo?(benjamin)
Comment on attachment 8820376 [details]
Bug 1324868 - invert `initial` flag in NarrateContols._setupVoices to correct value.

Gijs,

Can you give this one last glance with the telemetry rename? I want to push this up to beta, so another set of eyes is good.
Attachment #8820376 - Flags: feedback?(gijskruitbosch+bugs)
Attachment #8820376 - Flags: feedback?(gijskruitbosch+bugs)
Comment on attachment 8820376 [details]
Bug 1324868 - invert `initial` flag in NarrateContols._setupVoices to correct value.

(In reply to Eitan Isaacson [:eeejay] from comment #5)
> Comment on attachment 8820376 [details]
> Bug 1324868 - invert `initial` flag in NarrateContols._setupVoices to
> correct value.
> 
> Gijs,
> 
> Can you give this one last glance with the telemetry rename? I want to push
> this up to beta, so another set of eyes is good.

Sure, wfm.
Attachment #8820376 - Flags: feedback?(gijskruitbosch+bugs) → feedback+
Pushed by eisaacson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9ee2f4620247
invert `initial` flag in NarrateContols._setupVoices to correct value. r=Gijs
https://hg.mozilla.org/mozilla-central/rev/9ee2f4620247
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Comment on attachment 8820376 [details]
Bug 1324868 - invert `initial` flag in NarrateContols._setupVoices to correct value.

Approval Request Comment
[Feature/Bug causing the regression]: 1308030
[User impact if declined]: We won't have a useful metric for language support in Narrate.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No.
[Why is the change risky/not risky?]: It is a simple rename of a telemetry histogram, and a one line change that affects telemetry only and not anything user facing.
[String changes made/needed]: None.
Attachment #8820376 - Flags: approval-mozilla-beta?
Attachment #8820376 - Flags: approval-mozilla-aurora?
Comment on attachment 8820376 [details]
Bug 1324868 - invert `initial` flag in NarrateContols._setupVoices to correct value.

OK to uplift to aurora and beta, looks like a simple fix verified in nightly.
This should make it into the Beta 11 build on Jan. 2.
Attachment #8820376 - Flags: approval-mozilla-beta?
Attachment #8820376 - Flags: approval-mozilla-beta+
Attachment #8820376 - Flags: approval-mozilla-aurora?
Attachment #8820376 - Flags: approval-mozilla-aurora+
needs rebasing for beta
Flags: needinfo?(eitan)
My mistake. I thought this was already in beta, it is not. No need for uplift. Aurora is all we need.
Flags: needinfo?(eitan)
Attachment #8820376 - Flags: approval-mozilla-beta+ → approval-mozilla-beta-
You need to log in before you can comment on or make changes to this bug.