Check if xml-fetcher.js in url-classifier is test

RESOLVED DUPLICATE of bug 1297614

Status

()

P3
normal
RESOLVED DUPLICATE of bug 1297614
2 years ago
2 years ago

People

(Reporter: dimi, Assigned: dimi)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

2 years ago
When working on bug 1320402 ehsan found that xml-fetcher.js may not be test[1].
This bug is used to investigate if that is an untest path and add a testcase for it.

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1320402#c20
I think, when safe browsing code was moved from extension to be a part of Firefox, some parts are not being used (dead code probably).
For example xml-fetcher.js, trtable.js (or preference.js).
I don't see the Fetcher is being used currently, am I missing anywhere? (gcp could be have the better historical view of safe browsing code)
Flags: needinfo?(gpascutto)
That's correct. Also most stuff in content/moz is no longer used.

If you want to have a go at just removing them be my guest!
Flags: needinfo?(gpascutto)
(Assignee)

Updated

2 years ago
Assignee: nobody → dlee
Status: NEW → ASSIGNED
Priority: -- → P3
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1297614
You need to log in before you can comment on or make changes to this bug.