Can't style image selection with ::selection / ::-moz-selection

RESOLVED DUPLICATE of bug 292563

Status

()

RESOLVED DUPLICATE of bug 292563
2 years ago
2 years ago

People

(Reporter: marijnh, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8820685 [details]
Test page

Even when an image is styled with a `::selection` or `::-moz-selection` pseudo-element, it still gets a selected style (blue overlay) when selected. This seems contrary to the behavior of all other elements, and the behavior of images in Chrome and Safari, so I guess it is unintentional.

For an example, select across the image in attached HTML file.

Comment 1

2 years ago
Thanks for the report! It seems to be a duplicate of bug 292563.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 292563
You need to log in before you can comment on or make changes to this bug.